Jetson Linux R32.7.2 kernel driver build error #2

Hey,

I’m trying to make the kernel build from source but I’m getting this error: “/home/galaxiams/jetson_os/Linux_for_Tegra/source/public/kernel/kernel-4.9/Makefile:1122: recipe for target ‘drivers’ failed
make[1]: *** [drivers] Error 2
make[1]: Leaving directory ‘/home/galaxiams/jetson_os/Linux_for_Tegra/out’
Makefile:171: recipe for target ‘sub-make’ failed
make: *** [sub-make] Error 2”

The specific drivers it’s talking about seem to all be related to Ethernet and wifi drivers, and there’s multiple of these but this is one example: “/home/galaxiams/jetson_os/Linux_for_Tegra/source/public/kernel/kernel-4.9/scripts/Makefile.build:649: recipe for target ‘drivers/net/wireless’ failed
make[3]: *** [drivers/net/wireless] Error 2
/home/galaxiams/jetson_os/Linux_for_Tegra/source/public/kernel/kernel-4.9/scripts/Makefile.build:649: recipe for target ‘drivers/net’ failed
make[2]: *** [drivers/net] Error 2
make[2]: *** Waiting for unfinished jobs…”.

I’m running Ubuntu 18.04.6 and trying to build L4T 32.7.2 to have the same version as the other dev boards we have. The end computer will be the TX2 but I’m building on ubuntu with the GNU ARM Toolchain. I’ve tried a few things like make clean and tried to delete everything and start over fresh but that part of the build process doesn’t want to work.

Any troubleshooting tips?

Hi @luc4,

Could you share the steps you are following for compiling the kernel source, so that we can reproduce it and help you troubleshooting?

In case it helps you here are some instructions that can be applied for L4T 32.7.2 as well.

Embedded SW Engineer at RidgeRun
Contact us: support@ridgerun.com
Developers wiki: https://developer.ridgerun.com
Website: www.ridgerun.com

Note that the docs for your release will mention which toolchain to use.

You might find this of use. In particular, make sure the configuration part is complete before building. Once you’ve configured, if you are not building the Image target, be sure to run “make modules_prepare” first. I advise building the Image target at least once as a sanity check even if you only build modules. See:
https://forums.developer.nvidia.com/t/problem-smb-jetson-nano/193640/11