Jetson Nano + Deepstream + gstreamer + kinectv2

I loaded the “NVIDIA DLI course on DeepStream SDK” image onto my Nano and ran through the course.
When I was done I tried out some Gstreamer Commands.

Following the instructions of this github repo:
https://github.com/valdivj/Gstreamer_KinectV2

I was able to get the Kinect V2 to run in Deepstream on the Nano using this command:

gst-launch-1.0 freenect2src sourcetype=1 ! videoconvert ! 'video/x-raw,format=(string)YUY2' ! nvvidconv ! 'video/x-raw(memory:NVMM),format=(string)NV12' ! nvvidconv ! 'video/x-raw,format=(string)NV12' ! nvvideoconvert ! 'video/x-raw(memory:NVMM),format=(string)NV12' ! mux.sink_0 nvstreammux live-source=1 name=mux batch-size=1 width=1280 height=720 ! nvinfer config-file-path=/opt/nvidia/deepstream/deepstream-4.0/samples/configs/deepstream-app/config_infer_primary_nano.txt batch-size=1 ! nvmultistreamtiler rows=1 columns=1 width=1280 height=720 ! nvvideoconvert ! nvdsosd ! nvegltransform ! nveglglessink

The problem I am having is it only works on the “NVIDIA DLI course on DeepStream SDK” image.
When I try to recreate it on the regular Jetpack image and deepstream it dosent work.
It has to do with memory. I tried to duplicate the swap file of the “NVIDIA DLI course on DeepStream SDK” but no go.

Whats the difference between “NVIDIA DLI course on DeepStream SDK” image and the regular nano Jetpack image.

Never mind I figured it out.The Gtreamer command was trying to rebuild the engine every time.
Had to make sure config file was calling the the already built engine.
Will post videos of KinectV2 running deepstream tomorrow.

+1