Jetson nano fail to boot

Hi Guys. I’ve been battling to flash my Jetson Nano. I get an error every time I boot the system (may you kindly see attached). I’ve tried to follow steps on Jetson Linux , but when I have to run the command $ sudo ./ , it returns “command not found.” I have tried this using the latest Ubuntu version as I cannot get the older version 16.04 and 18.04. If there’s anyone that can assist I’d appreciate your help. If there are alternative methods, please share them here.

I think you could ask this question to yourself too. Where did you run this command?

If that script does not exist there, then of course it won’t work.

Hi Wayne, apologies. I ran this on Ubuntu 22.04.4 LTS. Could there be a way to go around it?


I mean where did you run this on your ubuntu 22.04?

This is just a script. Not a command. There is no default command on Ubuntu called

It is a bash script shared by NVIDIA… You need to download the whole package from our website. One of the tool inside the package is this one.

If you’ve installed the flash software on the host PC, then there will be a “Linux_for_Tegra/” directory somewhere. You’d have to first cd to that location before the command works from the host PC (if and only if the recovery mode Jetson has its USB connected).

Command line will work on an Ubuntu 22.04 host PC, but the GUI front end to the flash software, JetPack/SDK Manager, would not show the L4T R32.x flash software you want. You’d have to downgrade to Ubuntu 20.04. You can still install L4T R32.x flash software on an Ubuntu 22.04 host PC, but the steps will be manual. Some features of JetPack are quite useful, so I’d recommend downgrading your host PC to Ubuntu 20.04 instead.

If you’ve installed to the host PC via JetPack/SDK Manager, there will be this directory:

If you’ve manually installed, then there will be a “Linux_for_Tegra/” subdirectory wherever you unpacked at.

If you need to know how to install manually, just ask. The software and tools you’d want are the most recent L4T R32.x (L4T is what gets flashed, and is just Ubuntu plus NVIDIA drivers):

Note that a Jetson in recovery mode is a custom USB device. This means it needs a custom USB driver. The Jetson cannot self-flash, and the “driver package” runs only on a Linux host PC. The main restriction on the host release is due to the GUI software, not the driver.

Hi @linuxdev and @WayneWWW . Thank you all for your inputs. you’ve both shown me some of the mistakes I’ve been making. I’ve managed to go through all the steps as per the guide and when I check for the Jetson Nano connection to the host PC using lsusb, I’m getting a return of this format on one of the usbs “Bus Device : ID 0955: Nvidia Corp.” which is good. However when I flash using “sudo ./ ${BOARD} mmcblk0p1,” the response is
Error: probing the target board failed.
Make sure the target board is connected through
micro-B USB port and is in recovery mode.

this is how I’ve put the Jetson Nano in recovery mode(or assume I have), and please may you correct me if any of my steps were incorrect. Powered off the nano and connected FRC and GRN, then connected the micro usb to the jetson and the usb a to the host pc. I then connected the dc power source to switch on the Jetson Nano but the LED is red when it powers on. I then remove the jumper between FRC and GRND as per the instructions and the LED still remains red. I assume I might be doing something wrong ? Please advise ? The SD card in the Jetson Nano, is it supposed to be empty during this process?

Could you share the exact command you are running and lsusb result in the same terminal?

please find the attached image for you reference

Generally it would be better to share such info as text file.

It is fine for this time… but not a good idea to share this all the time… For example… your photo even cuts your command in half…

Is your host PC a VM ?

okay Wayne , noted will do that next time. I am using raspberry PI 4B

Sorry to say that. You just have another mistake here. You cannot use raspberry PI 4B to flash Jetson…

Raspberry PI 4B is also arm64 based CPU which cannot run the flash binary…
You need to get a natvie x86 host PC.

BTW, this is still not related to the detection of recovery mode. Just a new mistake.

The APX in lsusb usually shows up in a VM. If it is a VM, then you can expect other USB difficulties.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.