Jetson Nano: Failed to install sdkmanager_0.9.11-3405_amd64.deb

hi ~ Please guide to install sdkmanager on Jetson nano.
after install libgconf-2-4/ibcanberra-gtk-module ,it is still fail.

rogerroan@rogerroan-desktop:~/Downloads$ sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb
[sudo] password for rogerroan:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘sdkmanager:amd64’ instead of ‘./sdkmanager_0.9.11-3405_amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sdkmanager:amd64 : Depends: libgconf-2-4:amd64 but it is not installable
Depends: libcanberra-gtk-module:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi eggeggss,

Please run the deb file on your host ubuntu (16.04 or 18.04) machine.
Install the Debian package:

sudo apt install ./sdkmanager_0.9.9-2351_amd64.deb

Launch SDK Manager with the following command:


it’s still fail.
where is the sdkmanager_0.9.9-2351_amd64.deb?
I downloaded from official was sdkmanager_0.9.11-3405_amd64.deb

Hi eggeggss,

Sorry for typo, using “sdkmanager_0.9.11-3405_amd64.deb” is correctly.
This is the official release version.
What is your Ubuntu version?
Are you got the same error as your #1 comment?

my ubuntu version is
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
yes, the same error

Hi eggeggss,

Please try below command on host PC (not Jetson device):

sudo dpkg -i sdkmanager_0.9.11-3405_amd64.deb && apt update -f

On the host PC you might try this:

sudo apt --fix-broken install
sudo apt-get install libgconf-2-4 libcanberra-gtk-module
# Now install sudo dpkg -i sdkmanager_0.9.11-3405_amd64.deb

Also Python 2, but I’m not sure of the package name (probably “python2”).