SDK Manager Install Errors

First off I apologize if this is posted to the wrong area of the forums; I’m fairly new to the Nvidia developer forums.

That being said, when I’m attempting to install the Nvidia SDK manager onto my host machine, the normal apt install gives the unmet dependencies libgconf-2-4 and libcanberra-gtk-module but it is not installable, and then when attempting the dpkg method, I still get “sdkmanager depends on libgconf-2-4 / libcanberra-gtk-module but not installed” errors.

So what is it that I’m missing to get the install to work?

Try this on the host:

sudo apt update
sudo apt --fix-broken install
sudo apt-get install libgconf-2-4 libcanberra-gtk-module
sudo apt-get install python

Thank you very much!

This is still not working for me. When I get to the third command I get:

user01@X1-Carbon:~/Downloads$ sudo apt-get install libgconf-2-4
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libgconf-2-4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libgconf-2-4’ has no installation candidate

If you run this without libgconf-2-4, or perhaps even without libcanberra-gtk-module, does the python install work? Basically what is important is to get the correct version of python installed, and some systems will have another version by default.

linuxdev, I don’t know how to make the install skip over libgconf-2-4 and libcanberra-gtk-module. Is that what you mean by " run this without libgconf-2-4 , or perhaps even without libcanberra-gtk-module"? If so, please advise how to do it.

also, please weigh in on the error I am seeing (shown in my previous post): E: Package ‘libgconf-2-4’ has no installation candidate Why would that be?

@A.Ro :
Updates over time on most all Linux distributions will occasionally change which packages exist. For example, two packages may be consolidated, or one package may be split into two different packages with entirely different names. I don’t know about that specific package, but this particular fix was from when Ubuntu 18.04 LTS was new. This part is important:

sudo apt update
sudo apt --fix-broken install

…does this work? Hopefully you can end up with changing or removing broken dependencies such that you can install the SDKM “.deb” without complaints from the package manager.

This URL expands a bit on the topic, but be careful to note that this is from the PC, not the Jetson:
https://developer.ridgerun.com/wiki/index.php?title=Fix_broken_APT_after_JetPack_installation

@linuxdev, thank you! Yes, I have done these two steps, but the SDKM errors would persist still. The apt update for some reason would result in a bunch of warnings and 404 (page not found) errors. So, I suspect, my Ubuntu OS wasn’t whole at the time I attempted to install SDKM. Unfotunately, since then I completely hosed the system and need to reinstall Ubuntu first. I’ll let you know how it goes when I reinstall Ubuntu.

You could be correct, but it would be useful to know which URL gave the 404. If you get a chance to copy and paste the URL from the error it could help (and it wouldn’t hurt to reinstall as part of debugging).

The gist is that during package updates web servers are contacted, and then an architecture specific to that package is searched for. 404 indicates the file could not be found, but sometimes this is not an actual error. As an example, if you are searching for updates to a package which does not have updates, then it isn’t really an error. However, there are some older URLs which may be incorrect at times for arm64/aarch64 which would be a legitimate error. If this is a URL from NVIDIA it is something that can be fixed, but if it is a URL from the outside world, then it might just be something to ignore. Hard to say without seeing the full log.