Jetson Nano some GPIO giving 1.5v


In Jetson Nano I ran the simple_out,py script and measured the voltage on multimeter, only this BOARD pins 13,37,22,18,16 worked correctly i.e. 0 to 3.3V toggle, the rest were giving 1.5v, whereas the same script when executed on Pi works in all GPIO except pin 27 and 28 as being I2C.

As mentioned in GitHub readme pins 3,5,27,28,8,10 are not considered, but still the rest pins doesn’t give correct voltage level

What could be the problem because I searched for a level shifter jumper but couldn’t find it on the board.

I noticed that al the pins you say work properly are all connected to the same level translator U7.

I also had board pin #18 stay at a voltage level 1.8 Volts even though I had it configured as an input and had a 7,000 Ohm resistor pullup to 3.3 Volts.

I needed to do the following to get it to behave better:

  1. Configure as an output
  2. set the pin HIGH
  3. configure as an input.

After that, the pin idled at 3.3 Volts, however if I pulled the pin low and then released, instead of returning to 3.3 Volts, it returned to 1.8 Volts.

After reading the data sheet on the level translators, it appears they need at a minimum 10 milliAmps at their input-side to switch directions.

So I changed to using a 390 Ohm resistor as a pullup and everything works perfectly now.

As a test, try measuring the voltage on a pin and pulling it up to 3.3 Volts with a 1,000 Ohm or lower resistance resistor for a moment and see if it returns to 1.2 Volts or 3.3 Volts.

These autodirectional level translators seem to be a bit finicky.

Yes as alankilian’s comment, there are some requests on the drive strength, pull-up etc., please refer to the datasheet of level shift (TXB0108) for more details.

ok so for even output device like LED to work on those pin we need pull up resistor to get 3.3v

What is the idle solution at this point to get the same pins functioning the right way as that of raspberry pi

I would personally avoid directly powering an LED with GPIO. I’ll suggest adding a buffer.

I can add voltage level convertors also but the output logic from the pins are fluctuating.

@dusty_nv can you help with this issue as to how to troubleshoot it.