My Jetson Nano GPIOs don't work!

Hello everyone! I’m a beginner trying to set the GPIOs as input / output, but I couldn’t. I’ve tried lots of different codes without results. Furthermore, I’ve measured voltage between pins 2 and 6 (from the 40 pins connector), but I got 0 volts. I’ve tried measuring voltage between pins 1-6, but I got 0 volts too. It’s supposed to have 5 volts and 3.3 volts recpectively. Currently, I’m using a Jetson Nano 2GB. Please, I’d like your help!

hello juanpalaciosvargas,

had you tried this Jetson-GPIO python library that enables the use of Jetson’s GPIOs.

Yes, I tried to finish all this repository.
But in this line:

“sudo cp lib/python/Jetson/GPIO/99-gpio.rules /etc/udev/rules.d/”

I got this error:
“cp: cannot stat ‘lib/python/Jetson/GPIO/99-gpio.rules’: No such file or directory”

hello juanpalaciosvargas,

had you downloaded the source to Jetson.GPIO?
i.e. $ git clone https://github.com/NVIDIA/jetson-gpio.git

it’ll create ~/jetson-gpio/ then you should be able to copying the 99-gpio.rules file into the rules.d directory.
thanks

1 Like

-Hi. Yes, It works. I ran this code:
$ git clone https://github.com/NVIDIA/jetson-gpio.git

-Then, I was able to copy the file “99-gpio.rules”.
$ sudo cp /home/juanpalacios/jetson-gpio/lib/python/Jetson/GPIO/99-gpio.rules /etc/udev/rules.d/

So, I rebooted my Jetson Nano, in order to try an example from the /sample file.

$ cd /home/juanpalacios/jetson-gpio/samples
$ python3 simple_out.py

-So, this appear in the Terminal:

Outputting 1 to pin 18
Outputting 0 to pin 18
Outputting 1 to pin 18
Outputting 0 to pin 18
.
.

But, I got another problem. The “simple_out.py” example it’s supposed to activate the pin 12 (18 Board level), but I get 0 volts between PIN 12 and GND. I try measuring voltage between 5V and GND, and I got 0 volts too. Please, What else do I have to do?

hello juanpalaciosvargas,

there’s level shifter, please also see Applications Note of 40-Pin Expansion Header GPIO Usage Considerations for reference,
thanks

Hi JerryChang. In locals electronic shops I’m not able to find the Level Shift TXB0108.
But, I’ve found this. I’d like to know if it might works properly.

It is not validated on devkit. You can compare its characters to TXB0108

Hello again. I’ve tried to solve this problem, but I’ve couldn’t.
What I’ve done, it’s to activate only specific GPIOs but only as output.
I tried this module 03 Relay Board Shield, and it works perfect!
It’s like a shield module.

But, I’m only able to activate just 03 outputs. Furtheremore, still I’m not able to use GPIOs as input. I’d like to know if someone have used / found a similar board which works with inputs.

Thanks