Jetson Nano - sudo apt-get update not working [HELP!]

Setup:
Jetson Nano Developer Kit
NVIDIA DLI AI Jetson Nano SD Card Image v1.1.1

I am trying to get v4utils to install so I can view my go pro live camera. I am trying to follow the Nvidia “getting started with AI” course.

I have the Jetson Nano in “Headless” mode.

However, I can’t even install or update anything.

dlinano@jetson-nano:~$ sudo apt-get update
[sudo] password for dlinano:
Get:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Get:2 file:/var/visionworks-repo  InRelease
Ign:2 file:/var/visionworks-repo  InRelease
Get:3 file:/var/visionworks-sfm-repo  InRelease
Ign:3 file:/var/visionworks-sfm-repo  InRelease
Get:4 file:/var/visionworks-tracking-repo  InRelease
Ign:4 file:/var/visionworks-tracking-repo  InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]
Err:13 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
  Could not resolve 'ports.ubuntu.com'
Err:14 https://repo.download.nvidia.com/jetson/common r32 InRelease
  Could not resolve 'repo.download.nvidia.com'
Err:15 https://repo.download.nvidia.com/jetson/t210 r32 InRelease
  Could not resolve 'repo.download.nvidia.com'
Err:16 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease
  Could not resolve 'ports.ubuntu.com'
Err:17 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease
  Could not resolve 'ports.ubuntu.com'
Err:18 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
  Could not resolve 'ports.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-updates/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-backports/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-security/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/common/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/t210/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Any help is appreciated!

Hi bhogvu,

Issue fixed, please try again.
$ sudo apt-get update

IT IS NOT FIXED !

I just tried it again!

dlinano@jetson-nano:~$ ls
Backup  Desktop  examples.desktop  nvdli-nano  test.mp4
dlinano@jetson-nano:~$ sudo apt-get update
[sudo] password for dlinano:
Get:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Get:2 file:/var/visionworks-repo  InRelease
Ign:2 file:/var/visionworks-repo  InRelease
Get:3 file:/var/visionworks-sfm-repo  InRelease
Ign:3 file:/var/visionworks-sfm-repo  InRelease
Get:4 file:/var/visionworks-tracking-repo  InRelease
Ign:4 file:/var/visionworks-tracking-repo  InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008B]
Err:13 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
  Could not resolve 'ports.ubuntu.com'
Err:14 https://repo.download.nvidia.com/jetson/common r32InRelease
  Could not resolve 'repo.download.nvidia.com'
Err:15 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease
  Could not resolve 'ports.ubuntu.com'
Err:16 https://repo.download.nvidia.com/jetson/t210 r32 InRelease
  Could not resolve 'repo.download.nvidia.com'
Err:17 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease
  Could not resolve 'ports.ubuntu.com'
Err:18 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease
  Could not resolve 'ports.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-updates/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-backports/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-security/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/common/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/t210/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Looks like a network issue or a problem with your ISP. please try configuring Google DNS (or cloudflare DNS, or something else reliable), either on your nano or on your router. Failure to resolve means DNS is broken somewhere. Is the network up at all? Can you ping, say, 8.8.8.8 from your nano?

I do not think my network is the error though. I have tried multiple different networks, from my secure university wifi to my home wifi.

I am able to ping 8.8.8.8, but I still do not understand how to configure google dns to make this work.

dlinano@jetson-nano:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1012ms

dlinano@jetson-nano:~$ sudo apt-get update
Get:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.326  InRelease
Get:2 file:/var/visionworks-repo  InRelease
Ign:2 file:/var/visionworks-repo  InRelease
Get:3 file:/var/visionworks-sfm-repo  InRelease
Ign:3 file:/var/visionworks-sfm-repo  InRelease
Get:4 file:/var/visionworks-tracking-repo  InRelease
Ign:4 file:/var/visionworks-tracking-repo  InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.326  Release [574 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]
Get:6 file:/var/visionworks-repo  Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo  Release [2,003 B]
Get:8 file:/var/visionworks-tracking-repo  Release [2,008 B]
Err:13 https://repo.download.nvidia.com/jetson/common r32 InRelease  Could not resolve 'repo.download.nvidia.com'
Err:14 http://ports.ubuntu.com/ubuntu-ports bionic InRelease  Could not resolve 'ports.ubuntu.com'
Err:15 https://repo.download.nvidia.com/jetson/t210 r32 InRelease  Could not resolve 'repo.download.nvidia.com'
Err:16 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease  Could not resolve 'ports.ubuntu.com'
Err:17 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease  Could not resolve 'ports.ubuntu.com'
Err:18 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease  Could not resolve 'ports.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-updates/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-backports/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/bionic-security/InRelease  Could not resolve 'ports.ubuntu.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/common/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Failed to fetch https://repo.download.nvidia.com/jetson/t210/dists/r32/InRelease  Could not resolve 'repo.download.nvidia.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

I am gonna try reflashing the DLI image and see if that changes anything. This is an issue with the apt list that Nvidia seems to have on the image file. I can ping 8.8.8.8 but then

sudo apt-get update

gets me network-related errors that do not make sense at all.

On both your host PC and the Jetson, does this work?

host ports.ubuntu.com

This particular message is based on being unable to do a “host” (just as in the command above) lookup:

Could not resolve 'ports.ubuntu.com'

When I run “host ports.ubuntu.com” I see:

ports.ubuntu.com has address 91.189.88.150
ports.ubuntu.com has IPv6 address 2001:67c:1360:8001::22

I can then do this successfully:

ping 91.189.88.150

Every time you use a named address (versus a “dotted-decimal” address) DNS has to do a lookup and convert the name to an address. In the case of a dynamically configured ethernet port on a router this setup would normally be automatic (some exceptions exist, usually for security). If we know exactly how the networking is configured physically (which port of device goes to a switch or router, so on), then we can get an idea of where DNS is going wrong.

FYI, on the Jetson (or host PC if things are failing there), what is the output of “ifconfig” and “route”? These provide exact answers as to what the system actually wants.

It works on my Mac, but not Jetson DLI Nano terminal.

Mac:

Vasu<b>Mac:</b>~ vasubhog$ host ports.ubuntu.com
ports.ubuntu.com has address 91.189.88.150
ports.ubuntu.com has IPv6 address 2001:67c:1360:8001::22

Jetson Nano:

dlinano@jetson-nano:~$ host ports.ubuntu.com
;; connection timed out; no servers could be reached

I do not get how this helps me at all with the below command

sudo apt-get update

I can not change what apt-get does when getting the packages since it cannot find
ports.ubuntu.com.

Please try to focus on the actual command error, if you have a way to change the apt-get function to go to the decimal address then let me know.

The problem is 100% your dns configuration on the nano itself. You might try backing up whatever changes you made to the image and reflashing.

Can you post the entire content of your /etc/resolv.conf?

@bhogvu: how is your Jetson Nano connecting to the internet?

I saw the same issue as well, caused by my internet connection not working.

In case you are connected via Ethernet-cable to your PC (connection sharing), please note that after rebooting the PC you have to reconfigure the ‘connection sharing’

Maybe it helps …

I have already reformatted my entire SD card, and reflashed the image. This is nvidia’s problem that their image is for some reason not able to get a connection to ports.ubuntu.com

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about theactual nameservers.

nameserver 8.8.8.8
nameserver 8.8.4.4

I am able to ping ports.ubuntu.com from my local machine, but am not able to from Jetson Nano interface using the image above.

Aha. Ok. So systemd-resolvconf is in use. Ok. The changes in that file will be ignored. You will need to use the GUI (Settings app) / nmtui / nmcli to set 8.8.8.8 as dns.

You can also try flushing dns cache:

sudo systemd-resolve --flush-caches

If that doesn’t work… edit: backup and reflash I missed you already did that. Assuming you’re using JetPack 4.3, we have the same image (it’s Ubuntu, more or less), and my nano and Xavier can both ping that host so the image should be fine.

So, just in case you’re having trouble with nmtui, I changed my own configuration and made some screenshots. first, do “sudo nmtui” and choose the connection you’re having trouble with. Then change the settings as follows:

Select “ok” and then reboot. That will only change it for a single interface.

When you run systemd-resolve --status you will see:

Link 3 (eth0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
         DNS Servers: 8.8.8.8
                      8.8.4.4
          DNS Domain: ~.

If you want to change it globally, for every interface, for all domains, and turn on DNSSEC for good measure just inc case your ISP is part of the problem, you can create a file at /etc/systemd/resolved.conf.d/google.conf with the following contents:

[Resolve]
DNS=8.8.8.8 8.8.4.4 2001:4860:4860::8888 2001:4860:4860::8844
DNSSEC=true
Domains=~.

Then reboot and you should see the following when running systemd-resolve --status:

$ systemd-resolve --status
Global
         DNS Servers: 8.8.8.8
                      8.8.4.4
                      2001:4860:4860::8888
                      2001:4860:4860::8844
          DNS Domain: ~.
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Please try that and run apt-get update again. That should fix it. If you need to revert the changes, just delete google.conf and/or run “sudo nmtui” again.

FYI, the “apt” software uses named addresses in all of its configuration files, e.g., “ports.ubuntu.com”. Using “host ports.ubuntu.com” you will be able to see an IPv4 dotted decimal address of “91.189.88.150” if and only if DNS is working. In most cases it is the same to interchange “91.189.88.150” and “ports.ubuntu.com”, but there are cases where web servers are able to examine the named address and provide a different virtual web server. Sometimes addresses change even if the name is the same…thus among all of those reasons configurations normally use named addresses and depend on DNS.

DNS is an outside service and the Jetson will use DNS if it is configured, but in your case this is not configured and this is out of the control of the Jetson. Either the DHCP/router response failed to include DNS, or else something like a firewall is blocking DNS. There is no possibility that the Jetson can in any way fix this if this is not either hard wired in a configuration, or else set up with DHCP automatically. The Jetson is doing what any other computer would do with that network connection, and the result is not related to hardware (Windows, Mac, PC Linux…would all do the same exact thing).

I still did not see the output of “route” or “ifconfig”. We also don’t know what the actual wiring is (e.g., a local router or static configuration), so it isn’t even possible to help other than suggestions for alternate ways of setting up DNS.

There is actually fallback dns configured to Google DNS by Nvidia.

$ cat /etc/systemd/resolved.conf.d/nv-fallback-dns.conf 
[Resolve]
FallbackDNS=8.8.8.8

But my reading of the systemd-resolvd documentation is that such a fallback is only used if dns servers aren’t found. if one is found and is somehow misconfigured it could cause this kind of issue, but since it’s working on other machines… I’m guessing this could possibly be dns cache related, which is why is suggested flushing it.

In any case, completely overriding dns like in the above “/etc/systemd/resolved.conf.d/google.conf” should fix it, and DNSSEC enforcement will ensure no dns servers are used besides Google (i highly doubt an ISP dns is going to bother with that). The checkboxes in the nmtui above should also doubly ignore local DHCP asssigned DNS.

So I believe I know what the problem is.

The course that I was trying to follow “Getting Started with AI on Jetson Nano”:
https://courses.nvidia.com/courses/course-v1:DLI+C-RX-02+V1/courseware/b2e02e999d9247eb8e33e893ca052206/63a4dee75f2e4624afbc33bce7811a9b/?child=first#mac

made me think that I would not need an ethernet cable connection (AS THE REQUIREMENTS DONT LIST IT).

Moreover, the link that I provided above literally states that when in “Headless” mode there would be no need for network connection. Which therefore does not allow me to ping or even have an internet connection.

This now confirms that this image will not work for what I need to do as we will need to install things using apt-get install but without an internet connection it won’t be possible.

Any suggestions or thoughts?

Well. I suppose I should have asked for clarification on what you meant by “headless”. Glad you got it sorted out.

I’m afraid, in general, apt-get does require an internet connection to work. Also “ping”. There are offline sources installed by SDK manager but apt will probably fail since it also has online sources configured.

I should also have looked closer at this:

dlinano@jetson-nano:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
<b>^C</b>
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 received, <b>100% packet loss</b>, time 1012ms

In summary: you will probably need an internet connection to your nano for the courses. Ethernet should work. Wifi should also work if you have a card or supported usb adapter.

Hey mdegans,

I apologize for wasting some of your time.

What SD image file do you recommend for doing computer vision on both a CSI camera and a USB camera?

I was using the “DLI (Headless)” mode as it allowed me to connect my jetson nano to my computer and therefore didn’t have to use a separate keyboard and mouse.

No worries about time. I should have spotted the issue earlier. I overlooked the simplest possibility.

Re: SD image, I recommend the latest JetPack. I think the dlinano image is based on 4.2.2 and hasn’t been updated since, but I might be wrong.

4.3 has OTA updates so you can apt-get install any software, like on a Pi, rather than needing to sideload it with SDK Manager.

You can configure ssh and remotely connect to your nano via the normal image as well. Depending on what you want to do, it’s probably easiest to start with the jetson-inference project. It’s a good introduction and the code is clear and well commented.

Do you have any experience with programming languages? If you have a favorite, I can point you in some directions.

Hey Mdegans,

Yeah, I will most likely get that new image. I would like to know more about the ssh as that would be quite helpful I believe for sending files over to run on the nano. I know many programming languages and have done computer vision with Java.

But I know Python a lot more, so we plan on using that for our project.

I was about just about to start on the inference project actually if the gopro thing continued to fail or if we found the issue.

Here is our GitHub wiki for more info.
https://github.com/VasuBhog/Senior-Project/wiki

Hey. I totally forgot about this thread until the forum admin marked the solution. Sorry about that. I looked at your docs on GitHub. Nice work. Design is the hard part for me. Anyway, if you like Python, jetson-inference is probably still my suggestion to start with.