Jetson Nano & Waveshare Touch Screen not working

I’m on Jetpack 4.6 Jetson Nano. In reading other posts from a year ago touch screen access was having issues. Has the software progressed? I have a Waveshare 400x1280 touch screen and can’t get touch to work. If it doesn’t work I will need to move onto another model (suggest?) or another manufacturer (hate to do). Any ideas, help, point me in a good direction?

I have /usr/share/X11/xorg.conf.d/40-libinput.conf set to

Section InputClass
Identifier libinput touchscreen catchall
**MatchIsTouchscreen on
MatchDevicePath /dev/input/event*
Driver libinput

I had the USB plugged into the wrong spot. It now responds to touch. However, the locations of the touch responses are off. I flipped the screen 90 to have landscape and I think the touch is not translating the location correctly. Anyone have an idea? I have a support request into Waveshare.

Please contact the vendor to get support. Or other users may have the device and can share experience.

One needs to rotate the touch orientation to match the physical orientation.

  1. Create xorg.conf.d directory in /etc/X11, and copy 40-libinput.conf from /usr/share/X11/xorg.conf.d to new directory
    root@DEVELOPMENT-JETSON:/etc/X11# mkdir xorg.conf.d
    root@DEVELOPMENT-JETSON:/etc/X11# sudo cp /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/40-libinput.conf

  2. Modify 40-libinput.conf and add the Calibration Matrix option
    Section InputClass
    Identifier “libinput touchscreen catchall”
    MatchIsTouchscreen “on”
    Option “CalibrationMatrix” “0 1 0 -1 0 1 0 0 1”
    MatchDevicePath “/dev/input/event*”
    Driver “libinput”

90 degree rotation: Option “CalibrationMatrix” “0 1 0 -1 0 1 0 0 1”
180 degree rotation: Option “CalibrationMatrix” “-1 0 1 0 -1 1 0 0 1”
270 degree rotation: Option “CalibrationMatrix” “0 -1 1 1 0 0 0 0 1”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.