Jetson Orin 5.0.2 Linux 35.1 AV1 issue

Dear nvidia support.

I am using deepstreams nvv4l2av1enc which works fine except for forcing key frames using GstForceKeyUnit.

Is this a known issue?

Thanks in advance.

Please refer to this topic:
Gstreamer DS 6 on l4t 31.1.1 nvv4l2av1enc does not output IDR FLAGS

And check if the buffer has GST_BUFFER_FLAG_DELTA_UNIT for key frames.

Dear support,

I am parsing the AV1 header manually myself for each frame so I can see when there is an AV1 iframe or not.
It doesn’t seem that GstForceKeyUnit changes anything.

In addition my team member tried to use the multimedia API directly ( without Gstreamer ). It worked overall but still couldn’t force an iframe using “forceIDR” function.

Also checked on latest 5.0.2 Jetpack Orin AGX. Same result.

Keen regards,

We would like to confirm the issue. So in 01_video_encode, you have set the runtime option in AV1 encoding:

Runtime configurable parameter string should be of the form:
e.g. "f20,b8000000,i1#f300,b6000000,r40/1"

Property ids:
        b<bitrate>  Bitrate
        p<peak_bitrate>  Peak Bitrate
        r<num/den>  Framerate
        i1          Force I-frame

But Force I-frame does not take effect. Is it correct? If yes, we will try to reproduce the issue by running 01_video_encode.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.