Jetson Orin CAN Communication Issue

I have a pair of Jetson Orin. I am trying to follow the steps on this page and I am unable to install the kernel drivers or follow any of the steps after that. I would like to perform CAN communication protocol between the 2 Jetson Orin for testing and then perform it with the Jetson and a motor I have

Hi ssivakumar,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in use?

You could verify the following items one-by-one.

  1. internal loopback test for single CAN
  2. Transmit data from CAN0 to CAN1 on single device
  3. Transmit data from CAN0 of first board to CAN0 of another board

What’s the exact command you run and get the issue?
Is there any response after you run the command or full serial console log could be provided for further check?

My Jetpack version is 5.1.1 (I dont know if the last one is th or not, but it is the latest upgrade, I can verify and write in the next edited post) I am using the devkit.

I am unable to perform the internal loopback test.
$ sudo apt-get install busybox
all the commands following this in the CAN page of Jetson Orin, I am not able to perform. it just gives an error saying that the command cannot be done.
I can send a follow-up to this message with the serial log if needed or details of the error

Please share every command you used and any error messages on your terminal.
If there’s the serial console log, please also provide us for further check.

here are the commands i ran and the o/p i got

cat /proc/device-tree/mttcan@c310000/status - okay
cat /proc/device-tree/mttcan@c320000/status - okay
sudo apt-get install busybox
[sudo] password request - installed busybox
busybox devmem 0x0c303020 w 0x458 - devmem: cant open ‘/dev/mem’ : Permission denied
modprobe can - modprobe: ERROR: could not insert ‘can’: Operation not permitted

and all commands related to this after the following do not run

I will attach the serial console log soon

please use sudo for these commands.

$sudo su
#busybox devmem 0x0c303020
#busybox devmem 0x0c303020 w 0x458

Ok, will try and post the results

thank you for your help. running the commands in sudo worked. closing this now

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.