Jetson Agx Orin CAN communication

I have recently purchased Jetson Agx Orin 64 gb development kit.

Currently I have having problems with CAN communication. I followed instruction from Controller Area Network (CAN) — Jetson Linux<br/>Developer Guide 34.1 documentation

I did cat /proc/device-tree/mttcan@c310000/status - returned okay
Then following commands:
sudo apt-get install busybox
busybox devmem 0x0c303018 w 0x458
busybox devmem 0x0c303010 w 0x400

Command modprobe didn’t work, so I did everything with sudo.

sudo modprobe can
sudo modprobe can_raw
sudo modprobe mttcan

ip link set can0 up type can bitrate 500000
sudo apt-get install can-utils

When I tried, cansend can0 123#abcdabcd nothing happens.

I have also tried loopback test ( with sudo):

$ ip link set can0 type can bitrate 500000 loopback on
$ ip link set can0 up
$ candump can0 &
$ cansend can0 123#abcdabcd
Again, nothing happens on terminal.
What am I doing wrong or what I missed?
Thank you/

Hi marinkovicivan,

What’s your Jetpack version in use?

Could you try to use JetsonIO to enable CAN0?

Do you follow every steps in the instruction w/o any issue?

Could you also share the result on the terminal and the full serial console log for further check?

Hi Kevin,

I am using Jetpack 5.1.1.

CAN0 is enabled

I have shorted the Tx and Rx pins in order to see if anything is send, but as you can see cansend can0 123#abcdabcd doesn’t return anything.

Could you try to use Jetson IO to enable can0 with Jetson-IO as following?

1. Run Jetson-IO
$ sudo /opt/nvidia/jetson-io/
2. Enable can0 and can1
Configure Jetson 40pin Header -> Configure header pins manually -> Enable can0/can1 as following -> Back -> Save pin changes -> Save and reboot to reconfigure pins -> Enter
 [*] can0           (29,31)
1 Like

I have just tried it and cansend can0 123#abcdabcd still return nothing.

Any advice how to set can communication?

With if config, I get following:

an0: flags=193<UP,RUNNING,NOARP> mtu 16
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 10 (UNSPEC)
RX packets 5 bytes 40 (40.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 1 overruns 0 carrier 1 collisions 0
device interrupt 115

I have now went through over 50 links and none instruction is good for setting CAN communication.
cansend can0 123#abcdabcd still return nothing

Please refer to the following thread about our CAN verification on the devkit.
Jetson AGX Xavier Developer Kit CAN commmunication error - #8 by KevinFFF
It is on the Xavier AGX, but it should be similar for Orin AGX.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.