Jetson ORIN is not detecting my cuda instsallation

I have seen a few posts about this problem, where jetson_release -v does not detect cuda, jetson-stats does not detect cuda, and neither do programs im trying to install that depend on cuda.
my jetson_release -v output:

   * Jetpack UNKNOWN [L4T 34.1.1]
   * NV Power Mode: MODE_50W - Type: 3
   * jetson_stats.service: active
 - Board info:
   * Type: UNKNOWN
   * SOC Family: tegra23x - ID:
   * Module: UNKNOWN - Board: P3737-000
   * Code Name: concord
   * CUDA GPU architecture (ARCH_BIN): NONE
   * Serial Number: 1422022101753
 - Libraries:
   * cuDNN:
   * TensorRT:
   * Visionworks: NOT_INSTALLED
   * OpenCV: 4.6.0 compiled CUDA: YES
   * VPI: ii libnvvpi2 2.0.14 arm64 NVIDIA Vision Programming Interface library
   * Vulkan: 1.3.203
 - jetson-stats:
   * Version 3.1.4
   * Works on Python 3.8.10

my ./deviceQuary output:

./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "Orin"
  CUDA Driver Version / Runtime Version          11.4 / 11.4
  CUDA Capability Major/Minor version number:    8.7
  Total amount of global memory:                 30623 MBytes (32110190592 bytes)
  (016) Multiprocessors, (128) CUDA Cores/MP:    2048 CUDA Cores
  GPU Max Clock rate:                            1300 MHz (1.30 GHz)
  Memory Clock rate:                             1300 Mhz
  Memory Bus Width:                              128-bit
  L2 Cache Size:                                 4194304 bytes
  Maximum Texture Dimension Size (x,y,z)         1D=(131072), 2D=(131072, 65536), 3D=(16384, 16384, 16384)
  Maximum Layered 1D Texture Size, (num) layers  1D=(32768), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers  2D=(32768, 32768), 2048 layers
  Total amount of constant memory:               65536 bytes
  Total amount of shared memory per block:       49152 bytes
  Total shared memory per multiprocessor:        167936 bytes
  Total number of registers available per block: 65536
  Warp size:                                     32
  Maximum number of threads per multiprocessor:  1536
  Maximum number of threads per block:           1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size    (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch:                          2147483647 bytes
  Texture alignment:                             512 bytes
  Concurrent copy and kernel execution:          Yes with 2 copy engine(s)
  Run time limit on kernels:                     No
  Integrated GPU sharing Host Memory:            Yes
  Support host page-locked memory mapping:       Yes
  Alignment requirement for Surfaces:            Yes
  Device has ECC support:                        Disabled
  Device supports Unified Addressing (UVA):      Yes
  Device supports Managed Memory:                Yes
  Device supports Compute Preemption:            Yes
  Supports Cooperative Kernel Launch:            Yes
  Supports MultiDevice Co-op Kernel Launch:      Yes
  Device PCI Domain ID / Bus ID / location ID:   0 / 0 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 11.4, CUDA Runtime Version = 11.4, NumDevs = 1
Result = PASS

for example, my opencv cmake error output:

CMake Warning at cmake/OpenCVFindLibsPerf.cmake:45 (message):
  OpenCV is not able to find/configure CUDA SDK (required by WITH_CUDA).

  CUDA support will be disabled in OpenCV build.

  To eliminate this warning remove WITH_CUDA=ON CMake configuration option.

or :

CMake Error at modules/dnn/CMakeLists.txt:36 (message):
  DNN: CUDA backend requires CUDA Toolkit.  Please resolve dependency or

sudo apt install nvidia-jetpack returns nvidia-jetpack is already the newest version (5.0.1-b118).

not sure what to do. maybe i have to use SDK manager although finding a compatible ubuntu PC might not be the easiest


Could you try to add the CUDA path to the environment variable to see if it helps?
For example:

$ echo 'export LD_LIBRARY_PATH=/usr/local/cuda-11.4/lib64:$LD_LIBRARY_PATH' >> ~/.bashrc
$ echo 'export PATH=/usr/local/cuda-11.4/bin:$PATH' >> ~/.bashrc
$ source ~/.bashrc


I can now find CUDA when installing programs although jetson_release still can’t locate it, weird interaction but at least i can compile with CUDA. thank you

Hi @Elad-SH, I don’t believe that jetson_release tool has been updated by @Raffaello for JetPack 5.0 yet, so pleased stay tuned from him from further updates.

Jetson_stats is in release candidate
I fixed many stuff and should work, but if doesn’t let me know.

To install the rc, follow this link: Release 4.0.0rc2 · rbonghi/jetson_stats · GitHub

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.