Jetson Orin Nano,About Transferring Jetson Linux OS from Solid State

Hi,Engineer friend:
I have a kit,Jetson Orin Nano 8G Developer Kit.When I first used it,using a 256GB solid state as storage medium without using an SD card.
All my files are on this SSD.
Now, I want to transfer all my work to another SSD with a size of 500G.
Here comes the question,What is the method to ensure that the configuration and files I made on 256G SSD are fully ported to 500G SSD? In other words, is there any way for me to directly hold a 500g SSD and plug it into the Orin Nano to start, and it’s everything I used to have.
Looking forward to a reply.


I just answered a similar question today, and you can check it here:

ok,I understand what you’re saying.

  1. What I want to ask is if there are any methods to operate under Windows?

  2. I tried to connect to Windows using a solid-state box and found that I couldn’t open it using File Explorer. Many disks were displayed, prompting me to initialize. Why is this?
    But it can be opened in a Linux environment, and it is a Jetson Linux file system…

  3. My purpose in doing this is out of a naive idea: directly copy files from 256G SSD to 500G SSD under Windows, and then try to complete the migration?

I hope to answer each question one by one.


If you are using or want to use our tools, then the answer is clearly no.

Because Windows does not natively recognize ext4 partitions, whereas Linux does.

The SSD contains other partitions than the rootfs, so simply copying files may not work, but you can give it a try under Linux.

But why bother doing it under Windows when you have a working Linux host?

Ohh,bro,You’re right.

Why do I need to ask about any methods available under Windows?
Because it is impossible for us to provide a Linux environment for frontline workers through industrialization in the future.

I will try to borrow a solid-state box to copy Jetson Linux OS under Jetson Linux next.

Blessing me for achieving it

I tried copying files under Linux as mentioned yesterday and found that it couldn’t start.

I found that the solid-state devices I am currently using that can be booted have many partitions.

but,I just copied something from ext4.I think the reason for not being able to start is due to other partitions.

so,What are the other partitions? How to create it? And take out the files inside and put them on another SSD?


So I think that’s the reason.

I believe there are some tools available in Linux that can that you clone a whole disk which contains multiple partitions, but the issue is that because APP partition is located at the front of the disk, you’ll leave the last 250GB space of your new SSD unallocated, as you cannot enlarge partitions using space not contiguous to them.

In short, I’d still recommend our backup/restore scripts for handling your need.

I will operate here,“/hw/JetPack_5.1.1_Linux_JETSON_ORIN_NANO_8GB_DEVKIT/Linux_for_Tegra”.refer to

First of all, I will bring orin nano as for FORCE_ RECOVERY mode,and connect to host(ubuntu18.04).

Secondly, according to README,Execute the following command:
1. $ systemctl stop udisks2.service
2. $ sudo tools/
3. $ sudo service nfs-kernel-server start
4. sudo ./tools/backup_restore/ -b jetson-orin-nano-devkit
The problem has occurred, there is only one file in the Images directory, nvpartitionmap.txt,which contains:”board_spec,3767-300-0005-K.2-1-1-jetson-orin-nano-devkit-“.There are no mirrored files!

terminal display:

I’m not sure where the problem lies? Please answer,thanks…


why is nfs-kernel-server required here?
Can you attach the full log?

i don’t know why:nfs-kernel-server?I just followed the file operation.

I will upload the log, please take a look.thanks.

log.txt (96.0 KB)

this is operation source file.
README_backup_restore.txt (4.1 KB)


My bad here, I forgot it’s in the README.

This is not the log for backing up, and can you take a look?

i know,Forgot to change ”mmcblk“ to “nvme0n1”,ha!

but,prompt:Error: Invalid target board - jetson-orin-nano-devkit.

I use “orin nano 8GB devkit”,so,What is the name of the board?

” Where is the same value orias is used in used in the
command. (See more details in the table of device names in the “Introduction”
topic of Jetson Linux Developer Guide).“
Where is this ”Introduction“?where is “the table of device names”?


that should not happen.
Is jetson-orin-nano-devkit.conf present in Linux_for_Tegra?


Can you show the full log here?
I just tested couple weeks ago, and I’m sure it’s working fine with Orin Nano.

log.txt (6.1 KB)

Is it the reason for the wrong name?

This is my modified. sh file. (5.6 KB) (13.9 KB) (12.7 KB)


a trivial little error here…
You have to run the script under Linux_for_Tegra, because it is where the config file is located.

ye,You are a professional
Should I run these three in the ” `Linux_for_Tegra“ directory?


you just need to interact with, as it will internally call the other two scripts.