Jetson TX2 CPU Frquency

I use Tx2 EVB. I add to rc.local the call script:

jetson_clocks.sh
jetson_clocks.sh --show >> /home/nvidia/log.txt

I can see in file log.txt that all cores receive MinFreq equal to MaxFreq.
When I connect to the board with ssh, I can see that the setting is overwritten by some other program.
I have to note that I disabled ondemand script by using:
sudo update-rc.d -f ondemand remove

Hi Alexs66, you should wait 30 seconds after Ubuntu boots to desktop before running the script.

You can also monitor the current frequencies using ~/tegrastats

I use tegrastats for monitoring. What is a process that change cpu frequency to default value after running script in rc.local?
Can I disable this process like I did with ondemand?

Have you tried using nvpmodel instead?

That’s not a great solution. First, it makes the effective boot time much longer. Second, it’s very imprecise, and relying on timing is never a good engineering solution at this level.

What is the particular process that sets things up so they are “ready” for the clocks? There’s got to be something that the system can detect and trigger on to run the script, so that a systemd module file could be written to enable it. For example, if it depends on graphical-target.service, is that enough? Or what are the other actions that need to come before?

I also tried nvpmodel m 0. The same result.
I also need to run my application before desktop. I use /home/nvidia/.xsessionrc for run my script.