Max CPU/GPU Frequency at boot

Is someone can give the light on how to start the TX2 at max frequency / max power via kernel options ? I already know the trick using /etc/rc.local, sleep 10sec for jetson_clocks at boot time, but here I’m looking for something avoiding the need of doing that via /etc/rc.local or any shell script during boot.

While recompiling a custom kernel, I saw the CPU Frequency Scaling (CONFIG_CPU_FREQ) and get surprised to see that the default CPUFreq governor is turned on performance by default. I quote from the doc :

Use the CPUFreq governor ‘performance’ as default. This sets
the frequency statically to the highest frequency supported by
the CPU.

Somebody have knowledge, using a custom kernel, how to start the TX2 at max freq for both CPU/GPU ?

Hi agruet,

Have you tried the NVP model tool?

This tool allows you to change your energy profile.
I hope this helps you.

Greivin F.

Hello greivin,
Thanks for Your answer and for sharing. I already knew about nvpmodel -m X . however, in this thread I really talk about make the TX2 start at max freq, max power, natively without the launch of scripts or external binary.

Update 1 :
Rebuilding the kernel with CONFIG_CPU_FREQ disabled make all /sys/…cpu/cpu0/… curr_freq not available. So no way to monitor if the freq is at Max then.

You may try to modify this file /etc/systemd/

If you mean max frequency during boot stages, then I suspect this would be a “bad idea”. I say so because part of what boot stages do is set up stable clocks and power rails so that other software can start from a stable known state. The bare metal boot typically is only on a single core and many of the max performance steps related to multi-core do not even apply yet. Speeding up boot through this method would not be practical. It is everything which comes after serial console starts which delays boot in some sort of controllable way, e.g., disabling serial console itself (also not a good idea unless you have a good reason).