Script for maximum clockspeeds and performence


does anyone yet have a max-performence script like for the TX1?

TX1: Nvidia's Max Performance Script for Tegra X1 · GitHub

I´m not talking about Max-P, I mean real maximum, i.e GPU 1,3 Ghz and all CPU cores 2 Ghz.


Please see this post for enabling Denver2 and increasing clock governor frequencies:

Thanks Dusty.

Using nvpmodel -m with profiles is a very nice and comfort way.

Hi Dusty,

I only want to boom the performance whenever necessary but save power the rest of time.
After I run the is there a way to stop it?


Hi Ray, try running --help to see info about the store and restore commands. When the system is at it’s default clocks (i.e. before you run jetson_clocks), run --store. Then later after you have maximized the governors, you can run --restore to restore it to the way it was without rebooting.

Hi dusty,

Is there a way to make run at startup? I’ve tried the “Startup Applications” app but it doesn’t work (doesn’t run it as sudo I guess). I’ve also tried the following from [1]:

also didn’t work out. Is there a more straightforward solution to this?


Hi buraksoner, were you able to use the nvpmodel utility at startup instead?


Hi dusty,

No I haven’t yet tried nvpmodel.

By the way, it turned out the following method actually works, I just didn’t have rc.local running at startup

Thanks for the help,

I solved it this way:

On the TX2 I created a startup service named jetsonClocks.service with the below lines of code in it and put it in etc/systemd/system folder:

Description=Maximize Jetson Performance

ExecStart=/bin/sh /home/path/to/


In the file just put:

# Maximize performance on the Jetson
# How long would this hold up in a long environment? No idea

sleep 60

. "/home/nvidia/"

exit 0

Then you need to run the following commands to enable the service

sudo chmod 644 /etc/systemd/system/jetsonClocks.service
sudo systemctl daemon-reload
sudo systemctl enable jetsonClocks.service
sudo reboot


I am getting around 1.5-2x improvement in my application by running
Is it okay to use max clock all the time without worrying about temperature ?

Thanks for you help,
Shubham Jain

It shouldn’t matter, but it does turn on the fan at all times.

“” is a bash script, so it is human readable. There is a function within the script, “do_fan()”, which shows you can read fan speed setup via “cat /sys/kernel/debug/tegra_fan/target_pwm”, or write a number from 0 to 255 to manually set a speed. “255” is max, and “0” is automatic. If you run “” to set clocks to max, and do not want the fan to run except when needed, then you should be able to do this:

sudo echo 0 > /sys/kernel/debug/tegra_fan/target_pwm

FYI, you might consider “sudo nvpmodel -m 0” prior to This turns on Denver cores and may change some clock settings. Think of nvpmodel as determining what performance range is allowed, and as implementation of turning to max rate.

Note that there are some different device trees for 24x7 versus stock, and this might reduce the maximum clock speed…I’m not sure, but the intent seems to lengthen the life of a Jetson which is always running at max load (setting makes max possible, but it would still idle somewhat cool if not under a load…a combination of always being under load and having clocks maxed would probably imply it is of interest to see what 24x7 changes might lengthen life.

Can anyone comment on whether a 24x7 device tree is relevant here? I don’t know much about this, I just know it has come up in past conversations.