Jetson TX2 NX cifs relatime

I have recompiled my Jetson 4.6.0 kernel, 4.9.253-tegra as described here Problem SMB Jetson Nano

I get CIFS: Unknown mount option “relatime”
Any idea what I need to install or what module am I missing in the kernel?
I can’t find the cause anywhere online… :(

Not sure it if it helps but you may try
bash - unknown mount option `relatime' - Ask Ubuntu

See if setting norelatime helps.

Hi Dane,

Doesn’t help as I am using Kubernetes on it and seems it really wants to use relatime. And I prefer finding out how to enable the capability not deactivating it.

I know nothing about SAMBA, but I looked up some information on that error. I found an interesting bug report:

Do you have package “keyutils” installed?
dpkg -l | grep 'keyutils'

Apparently keyutils package and cifs-utils work together.

Hi linuxdev,

Yes I do:
dpkg -l | grep ‘keyutils’
ii keyutils 1.5.9-9.2ubuntu2 arm64 Linux Key Management Utilities
ii libkeyutils1:arm64 1.5.9-9.2ubuntu2 arm64 Linux Key Management Utilities (library)

I just did apt-get install keyutils and it updated it but same error. :(
P.S. cifs-utils is also present

This won’t necessarily depend on the Jetson hardware itself. It seems that this software has issues even on a desktop PC, perhaps related to more than one SMB protocol existing (different releases). I am not set up to recreate this, but I will suggest that you post on Ubuntu forums and ask about this. If nobody there answers, or if there is some question specific to the Jetson, then you could always come back here and ask more based on whatever you learn. I personally just don’t know enough about CIFS to debug other than looking up the issue on the internet since I have not tried to set up CIFS.

Ok, I will write there.
Thank you for your quick replies!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.