Jetson xavier nx camera's not work on cheese

I use Jetson Xavier NX and IMU219 camera.

That’s links :

I open cheese webcam but webcam says ‘no device found’. So

I run ‘ls /dev/video0’ on command an it says ‘/dev/video0’.

After when I run

‘gst-launch-1.0 nvarguscamerasrc ! ‘video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12’ ! nvvidconv flip-method=0 ! ‘video/x-raw,width=960, height=616’ ! nvvidconv ! nvegltransform ! nveglglessink -e’ , it says

'Setting pipeline to PAUSED …

Using winsys: x11 Pipeline is live and does not need PREROLL … Got context from element ‘eglglessink0’: gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL; Setting pipeline to PLAYING … New clock: GstSystemClock Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:725 No cameras available Got EOS from element “pipeline0”. Execution ended after 0:00:00.059461447 Setting pipeline to PAUSED … Setting pipeline to READY … Setting pipeline to NULL … Freeing pipeline … ’

At this time, the camera seems to turn on but can not turn on. How should do I ?

Need export DISPLAY then run the gst-launch-1.0 command.

export DISPLAY=:0
gst-launch-1.0 nvarguscamerasrc .........

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.