Jetson Xavier NX doesn't start to boot (goes to recovery mode after flashing)

I am now using custom carrier board + Jetson Xavier NX 16GB + NVME

I succeeded to flash and worked well.
I flashed about 10 Jetson Xavier NX modules well.

And I tried to flash 2 more modules but It failed.

I flashed them but these 2 modules didn’t start to boot and go to recovery mode always.

I can see the log while flashing via UART.
But, nothing is shown via UART in boot.
(It is same when I set the recovery pin to low. I checked recovery pin but it was 1.8V)

Log files said flash is done well.

[ 235]: l4t_flash_from_kernel: Successfully flash the external device
[ 235]: l4t_flash_from_kernel: Flashing success

And flashed NVME works well with other Jetson Xavier NX modules.

I changed the board but it showed the same problem.
I changed NVME but it also showed the problem.
I think that Jetson Xavier NX module made the problem.

How can I solve this?

I attached flashing log file and UART log file.

flash_1-4_0_20240229-115038.log (23.0 KB)
jetson xavier log 2(stuck in recovery) 240229.txt (87.1 KB)

Then does other module work with this carrier board?

Sure. Other modules works well.

I use custom carrier board + Jetson Xavier NX 16GB modules + NVME

I tried to change carrier board (Jetson + NVME are fixed) => same problem happened
I tried to change NVME (carrier board + Jetson are fixed) => same problem happened
I tried to change Jetson (carrier board + NVME are fixed) => problem disappeared

Then see if it also happens on a DevKit board.
If it does or you don’t have a DevKit, then please RMA this module.

Hello, I don’t have a devkit.
But, I have a RTSO carrier board instead.
I tested it in RTSO board and saw below message

I feel like you are not using the right Python version.
Change to Python 2 and try again.

At previous, carrier board connected to Ubuntu 20 and it makes problem.
I changed it to my computer which has Ubuntu 18.
(Custom board test had worked with Ubuntu 18)

RTSO carrier board doesn’t have NVME.
And I tired to flash Jetson Xavier internal flash.

It flashed well and booted well in RTSO carrier board.
I moved the Jetson Xavier module back to my custom board.
It booted well with NVME - already have been flashed.
At this time, Jetson module didn’t go recovery mode.

I tried to flash empty NVME using the Jetson Xavier module again.
With empty NVME, it started with internal flash - flashed in RTSO - of the module.
I set the pin and reboot to go Recovery mode.
I tired to flash with same Jetson Xavier module and same board.
And I succeeded to flash and the Jetson Xavier module can boot NVME.

It works but I cannot understand.

Is this module faulty or good?

I have one more module which has same issue.
Should I flash it to internal flash before flash NVME?

I don’t really know what you are talking about here.
Can you please make a summary?

  1. My custom Carrier Board
  • NVME
  • flash down to NVME directly
  1. Jetson Xavier NX RTSO carrier board
  • No NVME slot
  • flash down to Jetson Xavier NX internal flash storage

Two boards are different in storage.

The Jetson Xavier NX 16GB module failed to flash down at # 1. (go to recovery mode)
The Jetson Xavier NX 16GB module succeeded to flash down at # 2.

After flashing down at #2, the module succeeded to flash down at #1.

I don’t know what command you used to flash the NVMe drive, but yes, most of the time it’s required.

Should I flash Jetson Xavier NX internal eMMC storage at first?
I should not flash NVME directly? It is not recommended?

Why does other Jetson Xavier NX modules works well although I didn’t flash down internal eMMC?

That’s the point.

Here is my command to flash NVME. (I use 256G NVME)

sudo ./tools/kernel_flash/ --external-only -c ./tools/kernel_flash/flash_l4t_nvme.xml -S 220GiB --external-device nvme0n1p1 --showlogs jetson-xavier-nx-devkit-emmc nvme0n1p1

--external-only means no internal device (QSPI, eMMC) will be flashed.
Either remove that option or flash eMMC first.

You are right. That’s the key.
After remove the option, it works well.

But I don’t know why the problem happened.
The modules are new ones.

Because new modules do not have bootloader stuff unless QSPI is flashed.

Is there any way to flash bootloader only on the internal QSPI?

And as I said before some modules were working well with --external only option.
Why are they working?

sudo ./ --no-systemimg -c -c bootloader/t186ref/cfg/flash_l4t_t194_qspi_p3668.xml jetson-xavier-nx-devkit-emmc internal

Because they have been flashed before…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.