Jetson Xavier NX new module goes to recovery mode without pin setup

Hi, I setup Jetson Xavier NX(16GB) with NVME.
It boots from NVME and works well.

I changed Jetson Xavier NX module to new one. (programmed NVME is still on the board)

But my board doesn’t work, doesn’t start ubuntu.
I checked it with USB port and I found it goes to recovery mode.
I didn’t connect pin for recovery mode.

I turned off the board and turned on again. But result was same. recovery mode.

I changed the module with anther new Jetson Xavier NX module and got same same result.

Does New module always go to recovery mode without pin connection?
How can I leave recovery mode without flashing?

Does New module always go to recovery mode without pin connection?


You can try to directly flash the board to confirm what you said is correct or not. If it is really in recovery mode, you can directly flash it.

If it is not, then that is not recovery mode.

Are you sure that is recovery mode, and not just early boot? You really should post the serial console boot log even if you think it is recovery mode.

Incidentally, Jetsons don’t have a BIOS, they have the equivalent in software. For SD card models that content and boot stages are in the QSPI memory of the module, and in eMMC models, that content is in partitions on the eMMC. Commercial modules (those purchased separately, and not part of a dev kit) don’t have any of that flashed, whereas dev kits very often have a version too old to work…both must be flashed most of the time when you first get one. The NVMe likely has nothing to do with the boot issue…what you have flashed on the module probably does. Even if what is there is valid, likely it needs to have an initrd flash instead of a regular flash in order to point at the external media.

I got a new jetson xavier nx module (from sealed package) for one more test.
I made a set with new module and programmed nvme.

After power-on, I saw the ID “7e19” and it meant recovery mode.
And I tried to flash and saw “Success” message and saw it reboot and worked successfully.

if old module has the problem to always go to recovery mode, please RMA this module.

I know it doesn’t matter if I burned again. But, it takes time over 10 minutes.
If I should burn every time for new module although I already have programmed nvme, I need to spent a lot of time . Is there any other way (without flashing) to start to boot?

On SD card models, you really do have to flash the QSPI. On eMMC models, it is unlikely to contain the release you want, and even if they boot, they would still most likely require one flash. Some parts of the system have no other way to be updated correctly other than in recovery mode and flashing. The external storage only works if the rest of the system is valid and set up for the NVMe (you’d want an initrd flash for NVMe, which sets up differently than for an eMMC model or SD card model with the SD card as rootfs). Other than when you get lucky I don’t think you can get around this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.