Jetson Xavier NX: Messed up NvMe boot. microSD damaged

I had my NX to boot from 980 Pro NvMe however my microSd is damaged and I cant boot. I tried to run a factory reset/recovery using a J14 jumper on 9 and 10 to restore the unit so I can just create a new microSD Boot but I cant restore either. Can I load a kernel or bootloader on a new micro SD that will allow my Jetson Xavier NX to boot from the NvMe? If not , any other suggestions to get it running again? I get absolutely nothing on the screen so my hands are tied.

Saga continues. tried to flash with SDKM with fails all over the place. I have attached my log. (83.0 KB)

The last sdkmanager error you just posed is not a problem from your jetson.

It means there is error when running “apt-get update” on your host machine. Please fix that on your side first.

Since this is your host, we didn’t know what was added by you before. You are the one who can decide whether it could be deleted or not.

As for your device side problem, you can use the serial console on UART to dump log. This will tell more.

OK I have to buy a cable so keep this open for a few more days while I get my cable and upload the dump.


Ok Y’all, I tried and tried to flash Jetson Xavier NX unit with host, without host, with restore without restore with JP 5.0 and 5.1 - nothing. Blank screen Just reflashed normally but using 4.6.1 and booted right up! It appears to be an issue with JP > 4.6.1 IMHO.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.