Jetson Xavier NX Flashing issue - CPU Bootloader is not running on device

I tried to flsha L4T 32.5.1 stock bsp from Nvidia on our Xavier NX module emmc on our custom carrier board. My first attempt failed at the end (see attached log) of
[ 204.0958 ] [… ] 005%
Error: Return value 3
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

and then I have tried again and was getting CPU Bootloader is not running on device. error and flNX_Flash_issue_log.txt (2.3 MB)
ash fails, can you please suggest me on this? how to go further?

The NX module and Carrier boards are fine and the USB port also fine

Generally, analyze the flash log on host won’t have useful information.

Lots of causes will lead to CPU Bootloader is not running on device.

What you should provide is

  1. Will this module able to get flashed on devkit with same software? I guess the answer is yes.

  2. What is the hardware difference between your board and devkit?

  3. Have you ever checked the uart log during flash? Please be careful that I said uart log but not log from

1 Like

Hi Thanks for the input, finally it was faulty USB cable, I am able to flash after changing the USB cable

1 Like