Joint velocity control Franka panda

Hi, We’ve recently started to migrate our simulation to Isaacsim from gazebo. Following the tutorial here I’m able to position control the Franka Panda through ROS 1 with the omniverse action graph, which works nicely. However, when editing the script ros_publisher.py (in the isaac_tutorials package) to send joint velocity commands, the arm doesn’t move. Should the joint damping and stiffness values of the Franka Panda be modified in order to control joint velocity?

Is this with Isaac Sim 2022.1.1? There is a known issue with the velocity control in the Articulation Controller node. See this post for details.

Thanks for your reply!

I’ve looked at the other post, and it seems that is referring to another issue. I think to use revolute joint in velocity control mode, you need to set the stiffness to 0. This is also done in the code snippets section of dynamic control.

I’ve modified the Franka Panda usd file to set the stiffness to 0, and this works! However there is some drift in the joint positions, when no velocity command is given.

Did you add a some damping to the joint as well after setting stiffness to zero? Does that help with the drifting?

Yes I did add a damping term of 1e7 to all joints, maybe these damping terms are too low or high which causes drift. I will try out some different values and let you know.