Keeping Xorg's hands off a GPU (redeux)

Revisiting the issue “How do I set one GPU for display and the other two GPUs for CUDA computing?”

I want to do the same thing except have Xorg know only about a 1030 while reserving the 1070 for CUDA. But nvidia-smi reports the 1070 being used.

So I tried the first solution proffered by that post which was to specify the BusID and reboot. nvidia-smi reported the same thing.

So I tried the solution proffered in the final response, and reboot. nvidia-smi reported the same thing.

See this pastebin for the output of various logs and conf files.


one problem could be in line 32 of your pastebin: Files in cat /etc/X11/xorg.conf.d/ should end on .conf to wrok. Additionally see my config file I use for the same purpose but with one nvidia card and the integrated intel device. I tried to make the neccessary changes for you, but please check all identifiers and pci bus numbers:

 Section "Device"
  Identifier    "nvidia0"
  Driver        "nvidia"
  BusID         "PCI:a:0:0"
  Option        "Coolbits" "4"
  Option        "AllowEmptyInitialConfiguration"
  Option        "PrimaryGPU" "no"

Section "Device"
  Identifier      "nvidia1"
  Driver          "nvidia"
  BusID           "PCI:5:0:0"

Section "Screen"
  Identifier      "Screen0"
  Device          "nvidia1"

Section "ServerLayout"
  Identifier      "Main Layout"
  Screen 0        "Screen0"

In order to get the X server and the NVIDIA driver to not aggressively bind to every GPU they can find, you need to disable the driver’s ProbeAllGpus option in the Device or Screen section and the server’s AutoAddGpu option in the ServerFlags section.