Set up two K6000s to work with CentOS 8 in graphical mode

Hi all,
I recently added a second Quadro K6000 to my Linux machine to increase the memory capacity for using CUDA for cfd. However, after I installed the second GPU Linux will not boot in GUI mode anymore. I’ve tried editing the xorg.conf file with the BusID, but that wasn’t able to solve my problem. Please help me make GUI mode work with the dual GPU set up. Here is the bug report.
nvidia-bug-report.log.gz (1.6 MB)

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

Telling by your first post, I guess you don’t want to use the second K6000 for graphics but cuda only?
In that case, please try this:
and create a new /etc/X11/xorg.conf only containing

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddGPU" "false"

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:4:0:0"
    Option         "ProbeAllGpus" "False"
    Option         "SLI" "off"
    Option         "BaseMosaic" "Off"

and connect your monitors to the newly added K6000 since your bios decided that it is the new primary graphics adapter. If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

1 Like

It worked, thank you! The display output hasn’t changed though. Thank you for all you do and the prompt responses!

Ok, then the bios just changed the bus id, not the primary gpu.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.