Kubuntu 9.04 w/ beta driver black screen on dual 280M laptop

I just got the Alienware m17x w/ Dual 280M + 9400M graphics setup. I installed Kubuntu 9.04 without issues and installed all updates. When I install the 190.18 Beta driver, all I get is a blank screen once X starts. I know that it is running because if I blindly do Alt+Ctl+F1 login and type reboot, it reboots the system as expected.
I have tried all the various things suggested on this forum as well as the ubuntu and nvnews forums. Nothing seems to work.
I have attaced my bug report… I am not what you would call a gifted programmer and the output of the bug report means nothing to me.

nvidia_bug_report.log.gz (41.7 KB)

anyone from NVIDIA have thoughts on the issue?

I had a similar problem w/my cards: http://www.nvnews.net/vbulletin/showthread.php?t=135448

In your /etc/X11/xorg.conf:

You might try adding the BusId to the device section. The actual Id you use will need to match your system.

You probably need to set the SLI option as well.

Section “Device”

Identifier     "Device0"

Driver         "nvidia"

VendorName     "NVIDIA Corporation"

BoardName      "GeForce GTX 260"

<b>BusID          "PCI:2:0:0"</b>


Section “Screen”

Identifier     "Screen0"

Device         "Device0"

Monitor        "Monitor0"

DefaultDepth    24

Option         "TwinView" "False"

Option “SLI” “Auto”

SubSection     "Display"

    Depth       24



Well, it looks like the real problem is that the GPU’s aren’t getting recognized properly because I have 3, but the only entry in xorg.conf is

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”

lspci gives

02:00.0 VGA compatible controller: nVidia Corporation Device 060a (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation Device 060a (rev a2)
04:00.0 VGA compatible controller: nVidia Corporation GeForce 9400M G (rev b1)

I tried adding

BusID “PCI:2:0:0”, BusID “PCI:3:0:0”, and BusID “PCI:4:0:0”, and none of them seemed to help… Do I just have to wait for the next driver release and pray?

I guess the core of the issue is that I am not even sure how the GPUs are connected to the various outputs in a laptop, especially with this hybrid SLI business. What exactly does it mean to have discrete graphics in a laptop from the perspective of display adaptors? Apparently the NVIDIA driver isn’t able to figure it out either… this really limits my ability to manually configure the xorg.conf short of randomly guessing parameters.

Anybody from NVIDIA out there? I am truly lost here.

problem persists with the 190.32 Beta driver. I tried all the combinations of BusID 2,3,4 with this new driver without any luck.

Does anyone from NVIDIA have suggestions? It would be greatly appreciated.