tesla c1060 on ubuntu 8.04 problem with 180.60 driver

Hi,
I have sun ultra 40 m2 with quadro fx3500 running on ubuntu 8.04, and recently I’ve acquired C1060 card. I’ve installed the 180.60 driver, ran nvidia-xconfig and of course broke x server, that is the display(no 3d acseleration, low resolution, etc.). Is 180.60 driver compatible with fx3500? If not, is it possible to run two different drivers (one for fx3500 and other for c1060) on ubuntu? btw, he latest driver for fx3500 is 177.82.
best regards,
fantaz

Do you mean 180.06? There is no Linux 180.60 driver.

Its definitely not expected that installing 180.06 would “of course break the x server”. This sounds more like an issue where Ubuntu’s nvidia driver package is conflicting with 180.06.

180.06 supports the FX3500 and C1060.

First of all, thanx for a quick response.
To answer your question:
Yeah, I meant 180.06(lapsus calami), although nvidia’s site states “NVIDIA Driver for Linux 64-bit with CUDA Support (180.60)”, but the file is named with 180.06. I was mislead by the fact that the ubuntu start the failsafe mode everytime the xorg configuration fails, so I coudn’t see in the logs what was going on.
Anyway, it seems that my xorg.conf was a bit peculiar, so I had installed the drivers, ran nvidia-xconfig tool and changed the xorg.conf file by hand. Now everything works as described in installation manual (referring to nvidia-settings screenhot).

However, everytime the cuda code finishes, the screen turns black for second or two and then returns to normal. This shouldn’t happen, right? Does this mean that there is something wrong with installation and/or configuration, or this behaviour points to a hardware problem?
I was forced to use two 6-pin PCI Express power connectors which come from the same power rail (had to use splitter to ensure that the connectors come for the same power rail - one 6 pin PCIE power connector to two 6 pin PCIE power connector)
btw, i’m positive that the code executes on tesla, since the fx3500 is not cuda enabled.
best regards,
fantaz

Hello…

I hava a same problem with the coexistence of S870 and NVS290…

everytme when system starts, the xconfig file will be broken…

So since you have, to some extent, solved that problem, I wonder what you have appended in your xorg.conf file? Do you append a "–multigpu=MULTIGPU"annotation in it?

Thanks!!

The problem was that the nvidia-xconfig messed up the xorg.conf

I’ve learned that by mannually starting xserver (didn’t allow the ubuntu to go in the safe mode) (here’s how)

This doc was helpful for me too. The errors produced by the X were easy to fix in my case. (glx module wasn’t loaded, wrong screen and wrong graphic card).

Still, the monitor turns black for second or two when the cuda code finishes. It’s kinda bold statement without any evidence on my side, but maybe there is a bug in the 180.06 driver >.< .

Anyway, here are relevant sections of my xorg.conf:

Section "ServerLayout"

	Identifier	"Default Layout"

  screen 0 "Screen0" 0 0

	Inputdevice	"Generic Keyboard"

	Inputdevice	"Configured Mouse"

EndSection

Section "Screen"

	Identifier	"Screen0"

	Device		"Videocard0"

	Monitor		"monitor1"

	Defaultdepth	24

	Option		"TwinView"	"1"

	Option		"metamodes"	"DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1280+0"

	SubSection "Display"

		Depth	24

	EndSubSection

EndSection

Section "Device"

	Identifier	"Videocard0"

	Driver		"nvidia"

	Vendorname	"NVIDIA Corporation"

	Boardname	"Quadro FX 3500"

EndSection

Section "Monitor"

	Identifier	"monitor1"

	Vendorname	"Generic LCD Display"

	Modelname	"LCD Panel 1280x1024"

	Horizsync	31.0	-	64.0

	Vertrefresh	56.0	-	65.0

	Gamma	1

  modeline  "640x480@60" 25.0 640 656 752 800 480 490 492 525 -hsync -vsync

  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync

  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync

  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync

  modeline  "1280x960@60" 102.0 1280 1360 1496 1712 960 961 964 994 -hsync +vsync

  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

EndSection

Section "Module"

	Load		"v4l"

	Load		"glx"

EndSection

Section "ServerFlags"

	Option		"Xinerama"	"0"

EndSection

hope it helps a bit,

best regards,

fantaz