[SOLVED] Cannot properly install drivers on Redhat x86 r5 (Tikanga) for GTX 980, using LINUX X64 (AM

I downloaded the driver from Nvidia’s website, transferred it to my linux machine and followed the installation steps (Linux cannot access internet, so it was download to a Windows machine then transferred via USB stick). It says that it installs successfully. But once I reboot, X server says that it cannot start. Looking at the X server output, it says “NVIDIA: No matching Device section for instance…” Also, when I run “lspci | grep -i nvidia” The GPU comes up as “nVidia Corporation Unknown device 13c0 (rev al)” instead of its actual name.

As stated, I’m running Redhat x86 release 5 (Tikanga) and trying to use GTX 980.

Xorg.0.log (17.8 KB)
nvidia-bug-report.log.gz (45.3 KB)
nvidia-installer.log (101 KB)
Xorg.setup.log (1.13 KB)

If you want your devices to be properly identified, rpm -Uvh the hwdata package from Fedora Rawhide (it won’t break your installation - in fact it contains a textual database of PCI/USB devices).

Are you sure you have just one GPU installed?

(WW) NVIDIA(0): The NVIDIA Quadro NVS 290 GPU installed in this system is
(WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
(WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
(WW) NVIDIA(0):     information.  The 343.22 NVIDIA driver will ignore this
(WW) NVIDIA(0):     GPU.  Continuing probe...

From the logs you’ve posted it looks like you have two NVIDIA GPUs and that confuses the driver. Try to specify the GTX 980 PCI location in xorg.conf:

Section "Device"
        Identifier      "Videocard0"
        BusID           "PCI:1:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"

Unfortunately, changing xorg.conf to the above did not fix the issue. Granted, I’ve never messed around with X11 before.

And yes, I have 2 NVIDIA GPUs, the Quadro and the GTX 980. The Quadro came with the PC, and I use it to connect my 2 monitors to the computer. The plan for the GTX 980 is to do some CUDA computation on it. CUDA also is not running properly and wouldn’t detect the GPU without the driver, and now won’t detect any GPU with the driver (gives a devCount of o).

Post your xorg.log please (with the configuration file above enabled).

P.S. It makes sense not to disappear for weeks after asking questions. Some people aren’t patient enough.

Try using the full bus ID

To get it run

grep 'Bus Location:' /proc/driver/nvidia/gpus/*/information


Section "Device"
    Identifier "Videocard0"
    BusID "PCI:01:00:0"
    Driver "nvidia"
    VendorName "NVIDIA"

Your cards listed here are using the short ID

(--) PCI: (1:0:0) nVidia Corporation unknown chipset (0x13c0) rev 161, Mem @ 0xfa000000/24, 0xb0000000/28, 0xc0000000/25, I/O @ 0xdc80/7, BIOS @ 0xfbe00000/19
(--) PCI:*(2:0:0) nVidia Corporation unknown chipset (0x042f) rev 161, Mem @ 0xf7000000/24, 0xd0000000/28, 0xf8000000/25, I/O @ 0xcc80/7, BIOS @ 0xf6f00000/17

Xorg.conf requires the full format

(II) Primary Device is: PCI 02:00:0

I’ve posted the xorg.conf as well as some other logs/config files that may be helpful.

I did try to use the full format with “PCI:01:00:0” unless I also need to append the “0000:” but I haven’t seen an xorg.conf example that does that (again, I’ve never worked with xorg before).

And I should’ve apologized in advance: I’m in Japan and don’t have internet access on the weekends. That’s why my posting times are so strange and I was absent for a couple days. Thank you for any and all help.
xorg.0.2.log (25.3 KB)
Xorg.setup.log (1.13 KB)
driver.information.log (213 Bytes)
driver.registry.log (11 Bytes)
xorg.conf.log (1.63 KB)

Your Quadro card isn’t supported by the 343.22 driver so you need to plug the monitor into the GTX980 instead.

Okay. Reducing down to just the single GTX980 card worked. I’m guessing there is no way to have both GPUs in my computer?

Regardless, thank you and I’ll mark it as solved.

Have you tried the 304 series? It supports both cards …