Twin GPU problems in Linux

I’m trying to use CUDA on my workstation, and I’m running in to trouble when I add a 9800 X2 card for CUDA. The machine specs are as follows:
Intel Core 2 Quad Q9450
ASUS P5E3 Motherboard
4 GB DDR3 RAM
Fedora Core 9 OS (x86_64)
Linux -x86_64 177.13 Driver
CUDA 2.0b2 (x86_64)

In the top PCIe x16 slot, I have a GeForce 8800GTS. With this in place, I can run two monitors, and also run CUDA on the 8800GTS. This part is working fine (I know that FC9 is not officially supported).

Recently, I was given a 9800 X2 card, which I’d like to dedicate to CUDA. I’ve installed this in the second PCIe x16 slot, and put in a new PSU (which gives green lights on both power hookups). However, when I try booting the machine, X fails to start, booting text-only instead. Furthermore, theLooking at lspci, I find
[font=“Courier”]01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GTS 512 (rev a2)
02:00.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
03:00.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
03:02.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
04:00.0 3D controller: nVidia Corporation Unknown device 0604 (rev a2)
05:00.0 VGA compatible controller: nVidia Corporation Unknown device 0604 (rev a2)
[/font]

If I try issuing a ‘startx’ command, it fails with an error “No devices detected” I have tried reinstalling the driver, but that did not help. If I unplug the power cables from the 9800, everything goes back to normal (although the 9800 is obviously not present).

Any suggestions would be greatly appreciated.

I’ve been fiddling with moving GPUs in and out of my system. I found that the Bus id changed even when just adding the 2nd GPU.

Specifically, I had to change this line in the “Device” section of xorg.conf:
BusID “PCI:6:0:0”

If you run “X -configure” as root, it will generate a new xorg.conf file with the proper BusID lines written to it. I would just copy the new BusID over to the existing xorg.conf rather than replace it with the new one as Fedora probably has some distro specific stuff in there.

I tried running the NVIDIA Xconfig tool, but that didn’t do any good. I’ve just tried pulling the 8800 GTS, leaving the 9800 GX2 as the sole GPU in the machine. In this case, I can run the machine, and CUDA’s deviceQuery sample reports that two GeForce 9800 GX2 devices are present. Is there some prohibition against running two different cards on the same bus?

Nope: 9800GX2 + 8800 GTS is exactly the configuration I’ve got :)

Is lspci equally vague as to what’s there? As it is, I seem to have hosed my X installation trying to fix this :argh:

As an update, I eventually gave up, and reinstalled (I’d managed to hose progressively more of X11 along the way). Everything is now working as desired.