Ubuntu 8.10 Dual GPU Issues Unable to get two GPUs to coexist under Ubuntu 8.10


I’m not able to get two cards to work together. I have a GTX 295 which I want to use exclusively for CUDA and a 9400 GT. The reason for wanting to do this is to get around the time limit on kernel launches.

When I have two cards installed in the machine I get “Xserver fatal error: no screens found”. If there is only one card installed, it doesn’t matter which, there are no problems.

I appreciate this is really more of an operating system issue but the GTX is just a stop gap till we receive our Tesla cards. Those don’t have a graphics outputs so we’re really going to have problems the so better to get this solved now.

The system
-MoBo: Intel Skulltrail DX5400
-GPUs: 9400 GT, GTX 295 (and eventually Tesle C1060)
-OS: Ubuntu 8.10
-NVidia Driver version: 185.18.14 (x86_64 version, if that matters)

Has anybody had this problem?

Maybe there are some special settings, or flags, I need to set in /etc/X11/xorg.conf someone could let me know about…


did you solve this problem? i have the same problem :\

I am using Kubuntu 8.04 and I am also mixing and matching GPU generations. I have 8600/9600 for display and a 295 for CUDA. For some reason, when I look at the NVIDIA X Server Settings, they have the GPUs correctly numbered, but when I do a device query from CUDA, it gives the GPUs in a random order (i.e. GPU0 - 295, GPU1 - 8600, GPU3 - 295 while the correct order should be 8600, 295, 295).

Any thoughts?

You can kill X - server and work without it. No time limit on kernel launches in this way.

Anyway, have you tried to rebuild the driver? Do you use drivers compiled by your own or from Ubuntu repo?



That’s a bit weird. I never did solve my problem. One day the Tesla cards arrived so I removed the 9400GT, installed the Teslas and rebooted. Everything worked perfectly. Perhaps the GTX 295 and 9400GT just will not cooperate with each other. In any case everything works and I’m not going to waste any more time on it…

Re Killing X-server. True, but I like to use graphical editors. Also if I drop to run level 1 I think I can only have one terminal. Anyway, yes I always compile my own driver. I think this is the best policy.

I have a similar problem as to the OP. I have a ubuntu 9.04_AMD64 with geforce 7300GS/8600GT. The OS works fine but “nvidia-settings” only recognize the primary card 7300GS but can’t find 8600GT. “lspci” also does not show the hardware. Did you do some thing to see the GPUs? Anyone has a similar problem?

Sorry, it’s an hardware problem. I solved it.