Multiple 9800 GX2 not recognized

Hello,

I have recently bought two more 9800 GX2 for my system (x86_64, Fedora 8, kernel 2.6.23.1), which had only 9800 GX2 before. My problem is that I cannot use the second and third card. If I do:

/sbin/lspci | grep -i nvidia

I see:

01:00.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
02:00.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
02:02.0 PCI bridge: nVidia Corporation Unknown device 05be (rev a2)
03:00.0 3D controller: nVidia Corporation Unknown device 0604 (rev a2)
04:00.0 VGA compatible controller: nVidia Corporation Unknown device 0604 (rev a2)

and the output of

/sbin/lspci -t

is:

-[0000:00]-±00.0
±02.0-[0000:01-04]----00.0-[0000:02-04]–±00.0-[0000:03]----00.0
| -02.0-[0000:04]----00.0
±05.0-[0000:05]----00.0
±09.0-[0000:06]–
±12.0
±13.0
±13.1
±13.2
±13.3
±13.4
±13.5
±14.0
±14.1
±14.2
±14.3
±14.4-[0000:07]----00.0
±18.0
±18.1
±18.2
±18.3
-18.4

deviceQuery reports only two devices (0 and 1, corresponding to the first 9800GX2). What is the problem? What kernel option do I need to change or enable? What else do I need to do?

Thanks,
Luca

On Ubuntu x64 I didn’t need to do anything to recognize two GX2s, and I would expect the same for Fedora but haven’t tried it. (If it’s on the bus and alive, it should show up in lspci.)

Not an expert, but I would first check that the second GX2 shows green LEDs on both power connectors.

Then I would swap the new GX2 into the position of the first GX2 just to make sure it works as expected. I had to replace one of my two GX2s because it failed this particular test.

Also, on my particular motherboard (an evga 790i ultra SLI), the slot positions matter. For dual GX2s they must be in the upper and lower slots, not the middle slot, otherwise the BIOS complains. It doesn’t sound like your problem, but if your GX2s pass the swap test, then you’re probably having an issue with that second slot or with your power supply.

Here is an update. I did the swap test (trying one GPU card at a time) and all my GPU cards work. I’m trying to build the same machines that these guys in Belgium built: http://fastra.ua.ac.be/en/index.html (look at the specifications). I needed SATA cables with 90-degree connectors in order to the able to plug a GPU card on the second PCI Express slot (counting from the top). The 90-degree SATA cables were not shipped along with the cards and I got the cards first. So I started to play with just 3 cards and I plugged them in slots 1, 3, and 4. Only the first one was being recognized. I got the SATA cables late in the afternoon. So I tried just two cards, in slots 1 and 2. They are being recognized! I’m going to plug the other two cards right now… if I do not fall asleep!