NVIDIA Driver on Alma Linux 9 - black screen after login

I’ve installed Alma Linux 9 on a workstation with 2x A6000 installed (PCI slots 5 and 7 FWIW). Nouveaux drivers worked fine but I need NVIDIA ones. Did this via dnf and the NVIDIA RHEL9 repo

Now, whenever I boot using the NVIDIA drivers I can get to the login screen, but when I log in graphically the monitor turns off and I can’t get it back. Have tried nvidia-driver:latest-dkms and nvidia-driver:515-dkms with the same result. If I physically remove one of the GPUs then everything works fine. Have had a decent stab at fixing this myself (via google) but keep going in circles, any ideas?

nvidia-bug-report.log.gz (776.5 KB)

There’s basemosaic turned on but incorrectly configured. What kind of configuration do you want to achieve having two gpus?

Ahh right. The intent is that most of the time they’ll be used independently for AI work (pytorch etc) but one of them needs to be able to show a desktop.

Ok, please try this:

  • delete /etc/X11/xorg.conf.d/10-nvidia.conf
  • create /etc/X11/xorg.conf
Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:97:0:0"

You’re a legend, it’s working! We tried manually setting the BusID after auto-generating xorg.conf but that would just give us the blinking cursor instead of lightgdm login screen. I’m guessing there was a conflict with the 10-nvidia.conf file (or another setting in xorg.conf).

Thanks a lot. Should I look into manually fleshing out a more complete xorg.conf or will that example be enough for now?

You shouldn’t add anything unless you later want to enable some extra nvidia features. Modern xorg versions don’t need all the stuff about input devices, layouts, screens and monitors so it’s only confusing to read but pointless.

Great. Thanks again, was stuck down several Google rabbit holes trying to fix this but you’ve cut through all that, really appreciate the help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.