[SOLVED] Black screen before login screen with NVIDIA divers on Centos 8 Stream (GeForce GTX 3060 Ti LHR)

Got a new GPU and am switching over from and AMD to NVIDIA.
I have tried installing the driver from the Nvidia driver page as well as installing drivers from the https://developer.download.nvidia.com/compute/cuda/repos/rhel8/x86_64/cuda-rhel8.repo repo.
For the latter, I attempted both the latest-dkms and the 460-dkms versions.

For both the downloaded .run driver and the repo install I did:

  1. blacklist nouveau by creating /etc/modprobe/blacklist-nouveau.conf containing:
blacklist nouveau
options nouveau modeset=0
  1. Run systemctl set-default multi-user.target and reboot
  2. Install the drivers by running the .run binary or through from the repo with dnf
  3. Run systemctl set-default graphical.target and reboot
    At this stage, I get a black screen before the login page. When I switch to a TTY session, I get a blinking white line at the top of the screen and I can’t do anything. This happens for both installation methods.

I’ve tried all that I could find online, but haven’t been able to make any progress towards resolving the issue. I ran the nvidia bug report after installing the drivers from the downloaded .run binary, and have attached it.
nvidia-bug-report.log.gz.log (1.1 MB)

Any help would be greatly appreciated!

The Xservers seems to be starting but gnome-shell doesn’t. Please check what’s going on using sudo journalctl -b0

Thanks for the reply generix. I’ll have to re-install and check later today (had to reset the system to nouveau so I can work).
I did save this from dmesg when I last tried the install (forgot I’d saved this):

[   12.061678] gnome-shell[2966]: segfault at 0 ip 00007f62ae58e74a sp 00007ffca                                                                                                             a5175a0 error 4 in libc-2.28.so[7f62ae53b000+1bc000]
[   12.061683] Code: 41 54 45 31 e4 55 53 48 83 ec 28 48 89 74 24 08 85 c9 0f 85                                                                                                              90 02 00 00 83 fa 01 0f 84 8f 01 00 00 83 fa 24 0f 87 86 01 00 00 <49> 0f be 4d                                                                                                              00 49 8b 70 68 4c 89 eb 48 89 c8 f6 44 4e 01 20 74 12

I sshed into the machine when the black screen was showing, and this was at the bottom of the dmesg output. I can’t remember how exactly, but I was able to get this message output again if I restarted X. It was either through running systemctl restart systemd-logind or by killing the xorg process and running startx.

I was at a loss as to how to troubleshoot gnome-shell.

found this:

libglapi.so.0 => /opt/amdgpu

You have amdgpu-pro installed which blocks any other GL driver. Please uninstall it.

It works now! I uninstalled all the amdgpu packages, installed the Nvidia drivers using dnf and it’s all working perfectly.

Silly of me to overlook the amd drivers. I assumed the modprobe blacklist of them would be enough to stop them from interfering.

Thanks for your help @generix , much appreciated!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.