Kernel keeps restarting

Hello world!
I was trying to get roboflow for my jetbot but since then nothing works! :(
even a simple run kills the kernel

Can somebody help me figure out what happened? :(
Thank you!

Please see my response in the other thread you posted.

Oh apologies. I didn’t realize.
I’m using the jetson nano 4GB.
Please let me know if you need any other information ^^
Incase it helps:

If I remember correctly, this started happening after I tried to use a custom dataset I exported from roboflow and installed it (pip install roboflow), I had some errors and resolved them. Then tried running my files and this kept happening. I checked with other files that used to work and none of them could execute because of this issue.

I will move this over to the Jetson Nano category for visibility.


1 Like


It seems duplicate to the topic 205165.
Let’s track the following there.

Hi AastaLLL, do you mind linking it here? When I search that number I get brought back to here.

I ran pip list to see the versions that changed when getting roboflow and solve the issue by downgrading numpy to the jetson verison and editing the bashrc!
But now my camera is not working :(
It works in terminal and I’ve restarted it but it keeps crashing whenever I try to run a cell where I need to get camera feed with an error that the camera couldn initialize


Would you mind sharing the output log with us?

Sorry, which output log?
I actually think I messed things up more. I fixed the kernel restarting issue by getting the right numpy version. However, when I tried running the object following, I kept getting the camera failed to initialize error. I tried to restart the camera, restart the jetbot but nothing worked.
In case it helps:

So I thought maybe I could re-install jetbot.I uninstalled it but now I’m not able to install it back.
Is there a way to install jetbot or do I have to reflash the sd card again? :(


You should be able to install jetbot with the instructions shared below:

May I know what error do you meet when re-installing the software?

I ended up re-flashing and following the “Create SD Card Image From Scratch”
But I’m having issues with setting up jupyter status bar.

How can I go around this and make it so that I can connect to the nano through ip?



Do you use the image from jetbot link?
Or the base one from the JetPack page.

To confirm your setting, would you mind sharing the output of the following command with us?

$ sudo apt show nvidia-jetpack


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.