L4T R35.3.1 Ethernet (eth0) not working - Xavier NX

Hi, I recently updated my Xavier NX dev board via SDK manager from Jetpack 4.xx to 5.1. 1 - everything went right, but Ethernet port (eth0) although connected (1000 Mb/s) and having a valid IP adress does not work with internet. WLAN does. I tried different things including manual settings. The port does not provide internet access. Before (Jetpack 4.xx) there was never a problem. Is there a method to reactivate/repair Network functions of Ethernet0?
Kind regard

I faced something similar yesterday when upgrading an AGX Orin from R35.1 to R35.3.1.
The issue was that partition A_kernel-dtb was too small for the update. Are you sure that everything went fine ? Did you reboot after that ?

What gives:

cat /etc/nv_tegra_release

sudo apt dist-upgrade


If partition A_kernel-dtb (i think it is /dev/mmcblk0p3 but unable to check) has a small size (such as 367KB), you may have to enlarge it for successful update with new dtb.
There are some instructions in Release Notes, p.14, issue #3948609.
However these didn’t applied to my case with much less available room (NVIDIA: Is really 67.9MB the expected size ?).
I used gparted instead, increased A_kernel-dtb to 1MB after deleting A_reserved_on_user partition, then recreated A_reserved_on_user partition with the available room, then dkpg-reconfigured package nvidia-l4t-bootloader, then rebooted.
This time it found the new esp partition and UEFI updated. After that I had ethernet working again, and apt upgrade finished.

thank you very much for your quick reply and suggestions.

I am not 100% sure if really everything went ok. Before update I had a system booting from 64 GB SD to a 500 GN NVMe SSD. (procedure from jetson hack, oct 2018)

I updated with SDK Manager and Jetpack 5.1.1 (rev1). The Host machine was ubuntu 20.4, the connection via micro usb to an usb3 port (host). Actually I did the upgrade procedure twice (manually and automatic, with same result). L4T is now 35.3.1.

I installed all available packages including DeepStream…
all packages seem to be working, python, cv2, cuda …
the wired ethernet does not!

yes I rebooted after update

eth0 has a valid IP
wlan has a valid IP
both adresses respond to ping from a host.
ssh from a host also with both ip’s

Internet works only with wlan

lsblk on the xavier NX gives:
loop0 7:0 0 59,1M 1 loop /snap/core20/1883
loop1 7:1 0 53,5M 1 loop /snap/cups/873
loop2 7:2 0 91,7M 1 loop /snap/gtk-common-themes/1535
loop3 7:3 0 46,4M 1 loop /snap/snapd/19127
loop4 7:4 0 149,9M 1 loop /snap/chromium/2466
loop5 7:5 0 334M 1 loop /snap/gnome-3-38-2004/141
loop6 7:6 0 4K 1 loop /snap/bare/5
loop7 7:7 0 16M 1 loop
mmcblk0 179:0 0 59,5G 0 disk
├─mmcblk0p1 179:1 0 29,3G 0 part /media/marius/93eaaa63-ca0b-428c-b8a2-a15c66c5629b
├─mmcblk0p2 179:2 0 64M 0 part
├─mmcblk0p3 179:3 0 64M 0 part
├─mmcblk0p4 179:4 0 448K 0 part
├─mmcblk0p5 179:5 0 448K 0 part
├─mmcblk0p6 179:6 0 63M 0 part
├─mmcblk0p7 179:7 0 512K 0 part
├─mmcblk0p8 179:8 0 256K 0 part
├─mmcblk0p9 179:9 0 256K 0 part
├─mmcblk0p10 179:10 0 100M 0 part
└─mmcblk0p11 179:11 0 128M 0 part
zram0 251:0 0 571,2M 0 disk [SWAP]
zram1 251:1 0 571,2M 0 disk [SWAP]
zram2 251:2 0 571,2M 0 disk [SWAP]
zram3 251:3 0 571,2M 0 disk [SWAP]
zram4 251:4 0 571,2M 0 disk [SWAP]
zram5 251:5 0 571,2M 0 disk [SWAP]
nvme0n1 259:0 0 465,8G 0 disk
├─nvme0n1p1 259:1 0 465,2G 0 part /
├─nvme0n1p2 259:2 0 64M 0 part
├─nvme0n1p3 259:3 0 448K 0 part
├─nvme0n1p4 259:4 0 32M 0 part
├─nvme0n1p5 259:5 0 64M 0 part
├─nvme0n1p6 259:6 0 448K 0 part
├─nvme0n1p7 259:7 0 32M 0 part
├─nvme0n1p8 259:8 0 80M 0 part
├─nvme0n1p9 259:9 0 512K 0 part
├─nvme0n1p10 259:10 0 100M 0 part
├─nvme0n1p11 259:11 0 64M 0 part
├─nvme0n1p12 259:12 0 80M 0 part
├─nvme0n1p13 259:13 0 512K 0 part
└─nvme0n1p14 259:14 0 64M 0 part

I am not sure how to resolve the eth0 problem.
Do you think I should reflash QSPI and reinstall the jetson once again? Should I try an install from a SD card image? Should I change some config files on the SD card? I simply do not know what to try.

I do not want to mess up my jetson by doing completely wrong things with bootloaders, drivers UEFI … but I need the wired ethernet connection.

Kind regards


Hi, I just found out that eth0 works with internet when I connect to an old repeater with 100 MB port (same Network settings, same IP). So 100MB connection works, 1000 MB connection does not work. , although the cable is ok and connection is recognized as 1000 MB.

SSH connections via cable do work with 1000 MB port connected, but no internet??

I just found the solution: When I use a different (shorter, 2m) cat5E cable 1000 MB LAN is detected and internet works!! (The cable not working was also cat5e but 5m)

grrr sorry probably partly my fault. The ethernet port of the Jetson Xavier NX seems to be cable sensitive!!!

After some testing I found out that it is still neccessary to unplug and replug the ethernet cable after boot up in order to get a working Gigabit connection. WIth 100 MBit connections unplugging is not necessary.
So the ethernet connection has to be handled with care and probably some kind of update is necessary for jetson NX dev board.

Kind regards Marius

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.