Laptop crashes when connecting external monitors after botched driver installation

Machine specs: ThinkPad P53, i9-9880H, Quadro RTX 4000 Mobile (80W). On this machine, all external monitor connections are wired to the dGPU. Pop OS 20.10, running under hybrid graphics mode with Wayland.
You’ll have to forgive my ineptitude- this is hopefully the final step in my journey to switch to Linux as my host OS for the first time in many years. Although I’m not technically incompetent, this is my first time owning a dedicated graphics card, and the complex subtleties that go along with driving it on Linux are unfamiliar to me. I’ve uploaded my log file, and I can provide any other info needed.
While digging into a strange regression I encountered with 460.27.04 (hopefully more info on that soon), I decided that it might be a good idea to roll my driver back to the latest stable release (455.45.01) to check the difference. However, it would appear that I made a fatal mistake while doing so- I ran the 460.27.04 installer with the --uninstall flag, then rebooted before installing the 455.45.01 driver.
Doing so apparently has destroyed my Pop OS 20.10 install, as in any case I’ve tried since I did this a couple hours ago, connecting an external monitor to the device instantly causes it to freeze.
At first, it seemed that this was because the Nouveau driver was loaded in place of the proprietary drivers, so I set up the basic configuration necessary to stop the driver from taking over (modprobe configuration files, kernel blacklist) and after a couple reboots, between some tinkering and reinstalling the official drivers, I found that the nouveau drivers were unloaded and the official Nvidia drivers were loaded, but the freeze still occurred when an external monitor was connected.
I find it likely at this point that all hope is lost and I’ll need to reinstall the OS, but I’m hoping some of the smart people in here can do some digging and figure out a solution. Attached is my log file, taken right after my final attempt by uninstalling 455.45.01 and installing 455.38 directly from my package repository. Cheers to anyone who can help! nvidia-bug-report.log.gz (308.9 KB)

You’re running a wayland session, please try disabling it:

The freeze does indeed not occur while running an X session; however, this isn’t a very good solution. I am intentionally running Wayland in order to have proper support for fractional scaling. Furthermore, the crash occurs at the login screen, which makes it impossible to get to an X session in the first place unless I undock my machine, log in, and dock it again.
What could possibly have happened to mess everything up this badly?
Also, to the best of my knowledge, the usual incompatibilities of Wayland with Nvidia are avoided by using hybrid graphics mode and Reverse PRIME, as the Wayland session is running on the Intel GPU. Anecdotally, before everything broke, Wayland was a much smoother Reverse PRIME experience than an X session was.

Then try setting the kernel parameter
in order to use wayland.

Hey there, sorry for the delay; turns out Pop uses systemd-boot by default and I had the pleasure of learning how to work it.
Crash still occurs with the kernel flag you specified set. I hope this new log file nvidia-bug-report.log.gz (339.0 KB) helps… And I hope that I actually applied the flag, otherwise I’m going to look like a huge dolt. (How would I know if it worked, anyway?)

Doesn’look like it was correctly applied.

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return ‘Y’ if done right after reboot.

Using the command supplied, I can confirm that the kernel parameter was successfully applied, but the freeze still occurs.

I went to the trouble of performing a “refresh install” on Pop OS, which ended up not changing much.
It would seem that ever since I performed the botched uninstall of the driver in the first place, any sort of Wayland session immediately crashes upon connection to an external monitor. I was able to make this connection due to Wayland being disabled by default- enabling it reproduces the crash, while running a normal X session makes things work normally.

Running a normal X session on both 455.45 and 460.27 seems to prevent the laptop display from being output to, while Wayland works fine on the laptop display, but of course not on any externals. I vaguely recall having this issue a few months back (laptop display not working), the last time I tinkered with this, but I can’t remember how I solved it.

On the bright side, the install of 460.27 I initially had appeared broken upon further inspection- while playing with some benchmarking tools last week, I had found that all of them either crashed or refused to detect the Nvidia GPU, running on Intel instead. The install now works fine for render offload- I’m typing this from 460.27.

I’m curious as to whether Wayland working in the first place relied on this broken installation, or if something else is at play. I’m eager to hear any further advice on getting it running- and perhaps getting my laptop display back on X as well.

EDIT: The issue now appears to be related to the Intel graphics card- that is, hybrid graphics mode is no longer working at all. The iGPU seems to be completely unresponsive, and the X server is running on the dGPU. Sleep mode also fails, complaining about failing to suspend the Nvidia device. As aforementioned, I’ve had this issue in the past and was able to resolve it, but I can’t recall how. I’ve attempted to reinstall the 460.27 driver multiple times now to no avail.

nvidia-bug-report.log.gz (407.9 KB)