LibArgus Camera app setting the exposure value at max at startup

Hi,

Everytime I ran the libArgus sample “Camera” app, at startup, it will set both the exposure and analog gain value to max. Is there a way to configure libArgus or nvcamera deamon to not do this?

thx!

You may try --aelock=1 with argus_camera for disabling auto-exposure.
There are many options, I’m not familiar with this, but you may check https://devtalk.nvidia.com/default/topic/992898/jetson-tx1/acquisition-at-120fps-using-libargus-not-working/post/5142454/#5142454

With gstreamer, nvcamerasrc also has a property auto-exposure that should be set off with auto-exposure=1 and lock property aeLock that can be set to true:

gst-inspect-1.0 nvcamerasrc

I tried that and also the exposure range, but it does not change it. I wonder if this is some configuration settings thing.

@csuson
Why you just modify the default value as you want and build/compile it again.