Linux drivers for old NVIDIA GPU

Hello. I’m using kali linux. I have a HP Pavilion computer which has NVIDIA GeForce GT 740M gpu. I can use it on windows. But I changed the operationg system and still cannot fix the driver issue.
I almost tried every installation method and all the results are the same.
nvidia-smi returns with this error: NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
lspci | grep -i nvidia : 0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
Then I run nvidia-bug-report.sh
nvidia-bug-report.log.gz (123.6 KB)

Hi there @velizadetofiq1 and welcome to the NVIDIA developer forums.

Please purge all NVIDIA drivers first, then download the correct driver from Official Drivers | NVIDIA and read the README that is referred to on the results page under the Tab “Additional Information”

Especially follow the sections on linux headers and similar.

The log file showed several issues regarding pre-installation requirements which would take too long to describe here in detail.

Thanks!

1 Like