Linux graphics-driver install: sanity check fails on ubuntu 20.04

Tried with different driver-versions (510.73.05, 470.129.06).

Installation and usage of the driver is no problem but when running the -sanity-check of the .run file it returns a non-zero retval (1) with the following message:

ERROR: The installed symbolic link '/usr/lib/x86_64-linux-gnu/' no longer exists.

When checking the given file, it is a link to a non-existant file[driver-version].

We already tried removing the dead-link before running the sanity-check but the error stays the same.

Anyone any idea? i guess we have to wait for nvidia to fix this or is there something we can do to make the sanity-check work?

It’s rather the question why the original library doesn’t get installed/vashishes.
The .manifest file at least contains it 0755 OPENGL_LIB NATIVE MODULE:egl 0000 UTILITY_LIB_SYMLINK NATIVE MODULE:egl

We install the driver via ./ --no-wine-files -no-opengl-files --dkms -silent -e -k "${KVER}". @generix is the -no-opengl-files problematic in that regard? (Note that we also used this installation for all previous driver-versions where we havn’t had this problem)

Ok, this explains it and also shows where the bug is. While the lib has type OPENGL_LIB so doesn’t get installed with no-opengl-files, the symlink has type UTILITY_LIB_SYMLINK so is treated as utility and gets wrongly installed. Should rather have type OPENGL_LIB_SYMLINK.
Please send a mail to linux-bugs[at] since also the latest 515.48.07 driver contains this bug.