Linux Mint 19 switch to Intel graphics

Hi all, I have a MSI GL62M Laptop, I install Linux Mint 19 Cinnamon with dual boot. I am trying to switch to Intel Graphic but I couldnt. When I switch sometimes it freezes and nvidia-x-server-settings doesnt work. I purge and reinstall nvidia drivers. How can I fix this?

Here is my inxi -Fxz output:

roberto@roberto-GL62M-7RDX:~$ inxi -Fxz
System:    Host: roberto-GL62M-7RDX Kernel: 4.15.0-39-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Micro-Star product: GL62M 7RDX v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-16J9 v: REV:1.0 serial: N/A
           UEFI: American Megatrends v: E16J9IMS.31C date: 10/24/2017
Battery    BAT1: charge: 19.0 Wh 47.9% condition: 39.7/42.4 Wh (94%)
           model: MSI BIF0_9 status: Charging
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) 
           arch: Skylake rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 1071 MHz 2: 3040 MHz 3: 2989 MHz
           4: 3099 MHz 5: 2978 MHz 6: 2976 MHz 7: 3165 MHz 8: 3094 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.01hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.87 Direct Render: Yes
Audio:     Card Intel CM238 HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-39-generic
Network:   Card-1: Intel Device 24fb driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
           Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 1256.3GB (1.0% used)
           ID-1: /dev/sda model: TOSHIBA_THNSNJ25 size: 256.1GB temp: 48C
           ID-2: /dev/sdb model: HGST_HTS541010B7 size: 1000.2GB temp: 31C
Partition: ID-1: / size: 106G used: 7.4G (8%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 445G used: 184M (1%) fs: ext4 dev: /dev/sdb3
           ID-3: swap-1 size: 4.10GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: 27.8C gpu: 0.0:37C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 242 Uptime: 7 min Memory: 1127.9/7896.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Please try using kernel parameters

acpi_osi=! acpi_osi="Windows 2009"

Well, I reboot and use it and appear that System doesnt freeze. But the led indicator from my MSI power button is still orange. (Think needed to be blue if Intel is working as Graphic)

However I cant open my nvidia server settings to check it so I did this:

roberto@roberto-GL62M-7RDX:~$ sudo prime-select query
[sudo] password for roberto: 
intel

Well, is there another possibility to check if Intel Graphics is correctly working?

Thank you.

Running

glxinfo |grep vendor

should return

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: Intel Open Source Technology Center

That led indicator might be a software triggered one, only available through Windows software, don’t know though.

Well, that is exactly that glxinfo |grep vendor return.
So I can assume that Intel is working, sure? All time I think led indicator is hardware and not software.

Hope now, my battery improve his performance.

Thanks for your time.

To check that the nvidia gpu is off, run

sudo cat /proc/acpi/bbswitch

Here is my output:

roberto@roberto-GL62M-7RDX:~$ sudo cat /proc/acpi/bbswitch
cat: /proc/acpi/bbswitch: No such file or directory

Its the correct output?

The maybe Mint is now using runtime pm
cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status
should return
‘suspended’

Well, not luck with the return. I show you:

roberto@roberto-GL62M-7RDX:~$  cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status
active

I don’t know what kind of power management Mint currently uses, better ask that in the Mint forums.
You could also try to revert to a bbswitch based method:
https://devtalk.nvidia.com/default/topic/1032482/?comment=5290776

So basically I am using Intel Graphics but still on Nvidia?. I try to ask but its difficult to understand why are big differences among linux distro. I didnt know if I should to install another Distro to improve battery usage beacuse still on for 2 hours.

You are using the intel gpu but the nvidia gpu is still on so it consumes power though not used.

Well, I read your link and I see this: https://github.com/timrichardson/Prime-Ubuntu-18.04

Could work, I will try. Do you think its better update nvidia to the lastest versión from Update Manager?

Thanks for your patience