Linux (ubuntu) with nsight - not able to debug, even when no X is running?

I’ve been using CUDA C++ libraries (and thrust) for a while on Windows, Visual Studio 2010… works great, no problems.

Now, I’m trying to setup a development environment on some cloud compute servers, that have dual M2090 cards. However, when running nsight/eclipse, and trying to debug, I always get the following error when stepping through a cuda* function call:

“All CUDA devices are used for display and cannot be used while debugging”

I’ve read the other threads on this forum regarding this message, but it doesn’t seem like my problem is the same.

This happens even if I run remote debugging, and have the actual program running on cuda-gdbserver on a machine with no display/X11/VNC of any sort running. And the machine has TWO GPUs, so this is extra perplexing.

I can’t figure out how to get a debugging environment running on these servers.

They are Ubuntu 12.04 servers with 2 M2090s. Tried CUDA 5.5 and 6.0, same problem.

Any suggestions? Help very much appreciated.

Thanks,

-Peter

Are you certain that X is not running? Have you taken explicit steps to disable X?

http://askubuntu.com/questions/16371/how-do-i-disable-x-at-boot-time-so-that-the-system-boots-in-text-mode

That’s a good suggestion. I checked items listed in the article linked. I can verify that there is no vnc or *dm running of any sort, and grub is not being used to boot this server (they use some custom cloud server software for booting and image management).

I checked every running process, and I know what each of them is, and I’m 99% sure none of them are related to graphical displays (I recognize all of them, but you never know what you don’t know).