Llvmpipe instead of nvidia GPU, Vulkan

I am a new user of Ubuntu and I am currently learning C programming, specifically focusing on Vulkan.

A few days ago, I noticed that my system was no longer using my NVIDIA GeForce RTX 3080 graphics card from Aorus. Instead, it was using “llvmpipe (LLVM 15.0.6, 256 bits)” and I couldn’t understand why. I started to search for a solution to this problem.

I tried many things, including modifying the xorg.conf file to force the use of the graphics card, but it didn’t change anything. Then, I tried changing the driver, disabling Secure Boot, and many other settings, but nothing seemed to work. Finally, I decided to reinstall Ubuntu, and magically, my graphics card was working again!

However, the next day, while trying to figure out why my Vulkan program wasn’t working, I noticed again that my graphics card was disabled.

I’m starting to think that the problem may be due to all the manipulations I made with Vulkan, but I don’t know what to do anymore. So, I’m looking for any help possible to solve this problem.

Thank you in advance for your help!

my Vulkan project: GitHub - kodokaii/vulkan_first_project

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log (547.5 KB)

The kernel modules are missing. Please post the output of
dkms status