Loose drivers in ubuntu 8.04

I’ve managed to install CUDA on Ubuntu 8.04 32 bit with the help from http://lifeofaprogrammergeek.blogspot.com/…-in-ubuntu.html .

However, each time I restart my computer I seem to loose the drivers such that I can not run the examples. If I reinstall the CUDA drivers for the graphics card the examples works again…

This is the first time I run Linux so it might be a stupid Linux mistake.

Thanks for the link, I didn’t remember how to setup the variables for bash…

ammm, I think you can’t loose your drivers like that, if not, you will not be able to enter graphic mode and perhaps you will be kicked to a terminal indicating that the server has stopped working or some like that.

For see if you have your driver there, use

$ glxinfo | grep rendering

direct rendering: Yes

$ glxinfo | grep NVIDIA

server glx vendor string: NVIDIA Corporation

client glx vendor string: NVIDIA Corporation

OpenGL vendor string: NVIDIA Corporation

OpenGL version string: 2.1.2 NVIDIA 177.80

OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

you can see the complete output with only $ glxinfo

grep serve in this case for filter lines that are or interest. At less in this way, you will see if you have or not the driver (you should, if not, you will need the vesa default or some like that, but I think isn’t the case).

By the way, you can go to a terminal, and paste the lines you do when testing, the error is probable that shows there.

.< same problem here. Have to rmmod and modprobe every time I reboot.

After that building and demo are all OK, so the correct driver must be there. I wonder if there’s some older/deprecated driver not cleaned up, but can’t fix it anyway.

If you are able to enter graphic mode, then I guess you are using other driver… I mean, if there where noy loaded the driver for NVIDIA, how the system would be able to show you the graphics mode?? (you should be using some driver… if not how is that you see graphics?).

Before and after the manual load of the driver will be interesting to see the output of

glxinfo |grep render

glxinfo |grep NVIDIA

This is my actual xorg.conf, the important part for select the driver is Section “Device” Driver “nvidia”, also I guess it matter the Load glx.

Section "ServerLayout"

	Identifier	 "Default Layout"

	Screen		 "Default Screen" 0 0

	InputDevice	"Keyboard0" "CoreKeyboard"

	InputDevice	"Mouse0" "CorePointer"


Section "Module"

	Load		   "glx"


Section "InputDevice"

	# generated from default

	Identifier	 "Keyboard0"

	Driver		 "keyboard"


Section "InputDevice"

	# generated from default

	Identifier	 "Mouse0"

	Driver		 "mouse"

	Option		 "Protocol" "auto"

	Option		 "Device" "/dev/psaux"

	Option		 "Emulate3Buttons" "no"

	Option		 "ZAxisMapping" "4 5"


Section "Monitor"

	Identifier	 "Configured Monitor"


Section "Device"

	Identifier	 "Configured Video Device"

	Driver		 "nvidia"


Section "Screen"

	Identifier	 "Default Screen"

	Device		 "Configured Video Device"

	Monitor		"Configured Monitor"

	DefaultDepth	24

	Option		 "NoLogo" "True"

	SubSection	 "Display"

		Depth	   24

		Modes	  "nvidia-auto-select"