Nvidia 8400 card on ubuntu 8.04 (hardy heron) Driver installation problems

I am trying to install a new 8400 card on my desktop (dual core athlon) running kubuntu hardy (8.04). I intend to run cuda apps on it and so I guess I should be using this driver -> http://www.nvidia.com/object/thankyou.html…174.55-pkg1.run

I had also installed nvidia-glx-new using apt-get and i followed instructions in this post
http://www.nvnews.net/vbulletin/showthread.php?t=72490 to uninstall the those drivers to get rid of API mismatch errors.

I then reinstalled the CUDA driver above and it said it finished succesfully and also ran the nvidia-xconfig to update the xorg.conf which i verified.

I rebooted but Xserver fails to launch. I get a blank screen. I switched to a console terminal to check /var/log/Xorg.0.log and it has the following error messages in the end:

Failed to load NVIDIA kernel module
UnloadModule: “nvidia”
UNloadModule: “wfb”
UnloadModule: “fb”

Screen(s) found, but none have usable configuration

Fatal server error
no screens found.

Can someone please guide me.

Thanks

Also how do i find what version of 8400 card i have GS? GT or whatever…
Looking at the Qimonda chips, seems like the card has 512MB(512Mbx8)

Nevermind! Got resolved. I reinstalled linux-restricted-modules using apt-get and it worked. I ran the sample CUDA app deviceQuery and it said found 8600GT (to my surprise! :) …i thought I had an 8400.). Does this test confirm that my cuda device/driver is sucessfully installed and ready to run my apps?

Watch out for linux-restricted-modules. You might lose the new driver on the next reboot. I tend to uninstall anything related to NVIDIA kernel drivers and only install the downloaded driver, on Ubuntu.

If you’re good after the next reboot, then you’re good.

I have found that the following works for me on various Ubuntu Hardy boxes, and you can still keep linux-restricted-modules installed.

  1. Add “nv” to /etc/default/linux-restricted-modules-common

This ensures that the kernel module from the lrm-package is not loaded on boot.

  1. Install the drivers from NVIDIA-Linux-*.run archived

  2. Load the new driver by adding

insmod/ lib/modules/uname -r/kernel/drivers/video/nvidia.ko

to /etc/rc.local

(Notice that you must use " ` " and not " ’ ".)

Now pay attention to the upgrades, and rerun NVIDIA-Linux-*.run whenever there is a new kernel.

(A more elaborate script in rc.local could detect this and automatically compile the module as needed.)

This might not be the most elegant solution, but seems to be very robust and avoid destroying the Ubuntu package dependencies, or waiting for tools such as Envy to be upgraded with the latest (beta?) drivers.

Nice!

Just a note for others trying to get this stuff working…

I’m on

  • Dell Latitude D630 with an Quadro NVS 135M that’s got 256 megs of ram
  • Ubuntu Hardy (8.04) 64-bit

I uninstalled all nvidia related packages and then ran the install script that compiled its own kernel driver and installed the GL drivers. Initially I had problems with version mis-matches, so if you have had any nvidia drivers previously installed you might want to clean out your /lib/modules of old nvidia.ko files.

So, with the latest drivers I can compile both the Cuda 1.1 and the Cuda2 beta releases. 1.1 required installing gcc and g++ 4.1 as well as changing the symlinks in /usr/bin to point to them, while the beta2 did not.

I can compile most things and I can run the device query app. Beyond that, virtually nothing really works. The nbody and particle simulations come up, but no matter how I adjust the sliders they just blink non stop. If I step the animation by hitting return then they both just switch back and forth between two different states, which look like the initial configuration and some totally spazzed out state. Most of the demos I get a memory error, a segmentation fault or it will crash X or my whole machine.

I once had the simpleGL app running correctly, but after having tried one or two other failed demos it has gone back to the single red dot in the middle of the window that doesn’t move. That’s all I get for it now.

I’ve tried adjusting some of the parameters for demos like the oceanFFT to see if I could cut it down smaller to deal with what seems to be an out of memory error. (256megs seems sufficient for a little surface animation, but…???) No luck. Still get this error:
*** glibc detected *** ./fluidsGL: double free or corruption (out): 0x0000000000683490 ***

Any ideas or advice would be greatly appreciated.

I feel your pain! Every time I tried them I had problems with the installers from NVidia. I’m not sure that’s the reason for your issues, but I just thought I’d point you to this guide, it works well for me. Hope it helps!