driver 185.18.08 loads VESA for Ubuntu 8.04.2 with GTS250


I’m trying to install CUDA 2.2 on a new Ubuntu 8.04.2 64-bit workstation with a GTS250 installed. The 185.18.08 driver installs without any problems, however after rebooting using the “nvidia” driver in xorg.conf, it loads to a VESA 800x600 mode. Using the “nv” driver works fine. I’ve attached the output of xorg for both the nvidia and nv drivers, as well as a copy of xorg.conf.

Any help much appreciated.

xorg.conf.gz (701 Bytes)
x_nv.log.gz (8.74 KB)
x_nvidia.log.gz (7.15 KB)

You will need to uninstall the nv driver first (and make sure that no NVIDIA drivers from the Ubuntu repository are installed), then run the installer. There is at least one library conflict between the Ubuntu nv package and the NVIDIA driver that will cause the NVIDIA X11 driver to fail to initialize, even after a clean install.


I solved my own problem in the end. The open source “nv” driver doesn’t affect the proprietary “nvidia” driver. You don’t need to uninstall. What you do need to uninstall is the “nvidia-kernel-common” package before installing the proprietary driver. So (for Ubuntu 8.04):

[codebox]sudo apt-get remove nvidia-kernel-common[/codebox]

then log out, stop X

[codebox]sudo /etc/init.d/gdm stop[/codebox]

reinstall the driver, remove the kernel module from memory:

[codebox]sudo modprobe -r nvidia[/codebox]

and run

[codebox]sudo depmod -a[/codebox]

just in case. (Not sure if this last step is actually required, but it only takes a second.)

Then restart X:

[codebox]sudo /etc/init.d/gdm start[/codebox]

and it worked.