Low frame when encoding 1080p@30fps with h264/h265

My understanding is that the AGX Xavier Dev Kit should be able to encode at (2x) 4Kp60. Following the Accelerated GStreamer User Guide, I tried encoding a 1080p@30fps video to a file using this command:

gst-launch-1.0 nvarguscamerasrc ! \
'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, \
format=(string)NV12, framerate=(fraction)30/1' ! nvv4l2h264enc \
maxperf-enable=1 bitrate=8000000 ! h264parse ! qtmux ! filesink \
location=filename_h264.mp4 -e

However, I find that while 720p encodes without issue, encoding at 1080p causes the video to drop to ~1fps when played back. What am I missing here? I’m using a 4k CSI camera, and I’ve already tried enabling MAXN and jetson_clocks before encoding. I found that the same issue also occurs when using nvgstcapture-1.0 to do the recording/encoding.

nvgstcapture-1.0 -m 2 --video-res=4

The problem might be in playback. Totem in Ubuntu often fails to play.
What gives (assuming you’re running X):

gst-launch-1.0 filesrc location=filename_h264.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! nvvidconv ! videoconvert ! xvimagesink

Oh interesting, you were right. I tested playing back with gstreamer with your command as well as copying the file over to my laptop and both playback was smooth. Thank you!