Low resolution on detectnet output

I’m using one of my own trained models and running it through the included detectnet script. I am inputting my data from a video file and exporting the output to another video file using:
detectnet --model=<YOUR_MODEL> --labels=<YOUR_LABELS> --input=blob_0 --output-cvg=scores --threshold=0.1 --output-bboxe=boxes "VIDEO_FILE_INPUT.mp4" "VIDEO_FILE_OUT.mp4"

My issues is that the video file that get imported is 1280x1024, it then displays the output on the openGL window which is a resolution equal to the input. However, the saved video file looks terrible even though the properties show that its the same 1280x1024.
I was thinking that it was the output bit-rate however, I doubled the bitrate option and saw no difference. I cant seem to find anywhere else, even in the detectnet code that specifies the output resolution. I am thinking its somthing to do with the gstreamer pipeline as it compresses the video however thats a bit over my head.

Any help appreciated.


detectnet use jetson-utils to encode a video stream with GStreamer frameworks.
You can find the detailed pipeline below:

You can try to modify the bitRate or quality-level to get the quality you preferred.

Hi @sfn640, if you are running this in the container, can you try building from source and running it outside of container?

I’ll give it a try today

By building it from source and increasing the bitrate option I now get a really nice video output. I still don’t really understand why running it in the container would reduce the resolution. I there a bit rate limitation when creating files within a docker container?

Hi @sfn640, as per this suggestion, I modified the docker run script to mount /etc/enctune.conf into the container (see commit 68867c5)

Can you try pulling from master, or applying that same change from 68867c5, and confirming that it works inside the container for you (with high video quality)?