MaskRcnn on Jetson nano

Hello, I want to make a compact production quality inspector with Jetson nano as processor. I chose MaskRcnn because the model supports instance segmentation.
There is a sample called sampleuffMaskRcnn in the TensorRT repo on github. When I read through the TensorRT Release Notes I noticed that the sample is “not applicable for Jetson Platforms”, what does that mean?
I have followed the steps on the sampleuffMaskRcnn page and converted the .h5 weights to .uff file. And when I ran the sample , the programm always get killed approximately due to low memory.
My nano is flashed with the latest SD card image, namly with TensorRT 6.0.1, CUDA 10.0, Cudnn 7.6 installed.
Other package versions are Tensorflow 1.13.1, keras 2.1.3.
Please help, thanks in advance.


We have tested MaskRCNN on the Xavier and it can work without issue.
However, we haven’t tried it on Nano before.

There are two possible cause of your issue.

1. Some required steps is missing.
To check this, you can follow the instructions shared in this comment:

2. Running out of memory.
This issue can be confimed by monitoring the system status with tegrastats.

sudo tegrastats


thanks AsataLLL! The Memory consumption on nano is almost 100% of the 4GB RAM. So I mount another 6GB swap file.

I will try again using the instruction for Xavier to see if it can work on nano.


It may take more memory when converting the model into TensorRT.

It’s recommended to check the memory usage again once having the TensorRT engine.
If the memory usage not reaches 4GB, it will be faster without using the swap space.