MCX354A-FCBT does not show "Port Protocol" tab in device manager after FW upgrade

After upgrading my MCX354A-FCB_A1 network adapters to FW 2.33.5100 the “Port Protocol” tab in the Windows 7 device manager is not available anymore

(it was before), as shown in the ConnectX®-3 VPI Single and Dual QSFP+ Port Adapter Card User Manual Rev 2.4, page 59

However, I may change the port type successfully using the CLI:

mlxconfig -d /dev/mst/mt4099_pciconf0 s LINK_TYPE_P1=<1|2|3> for P1, port type: IB = 1, ETH = 2, Auto =3

mlxconfig -d /dev/mst/mt4099_pciconf0 s LINK_TYPE_P2=<1|2|3> for P2, port type: IB = 1, ETH = 2, Auto =3

REMARK:

The documentation Mellanox Firmware Tools (MFT) User Manual Rev. 2.3, § 2.1.1.1 on page 21, table 3, VPI settings is incorrect,

VPI_SETTINGS_PORTx should appear in the description column, in the parameter column it should read: LINK_TYPE_Px

It seems that the network adapters are not being recognized as VPI cards under Windows 7, x64 anymore ?

How can I correct this ?

BR speedy

Hi,

my question was on how to change it with the Windows device manager !

I know that it can be changed with mlxconfig etc. I gave this information in my original email already.

Is the “Port Protocol” tab available anymore or is this a problem with my setup / machine only ?

BR

speedy

Hi,

Please check How to change MCX354-FCBT port type under Windows 7 device manager https://community.mellanox.com/s/question/0D51T00006RVtW5SAL

It can be done with MFT toolkit